Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Error - Install YARN MapReduce Framework JARs on service YAR

avatar
Frequent Visitor

Hi Pros,

Current version:

  • Cloudera Manager 7.11.3.0
  • Cloudera Runtime 7.1.7 SP1

Upgrade version:

  • Cloudera Manager 7.11.3.14 (CH7)
  • Cloudera Runtime 7.1.9 SP1

I'm in the midst of upgrading Cloudera 7.1.7 SP3 to Cloudera 7.1.9 SP1. I encountered error at  Install YARN MapReduce Framework JARs on service YARN. I have screenshot and full logs but unable to upload here due to no permission. Below is an extract of the error logs.

/user/yarn/mapreduce/mr-framework - have executable rights.

Appreciate if anyone could point me to the answers.

Thank you very much.

25/07/18 12:59:43 ERROR uploader.FrameworkUploader: Error in execution /opt/cloudera/parcels/CDH-7.1.9-1.cdh7.1.9.p1000.55406660/lib/hadoop/./ozone-filesystem-hadoop3-1.4.0.7.1.9.1000-103.jar (Permission denied)

java.io.FileNotFoundException: /opt/cloudera/parcels/CDH-7.1.9-1.cdh7.1.9.p1000.55406660/lib/hadoop/./ozone-filesystem-hadoop3-1.4.0.7.1.9.1000-103.jar (Permission denied)

at java.io.FileInputStream.open0(Native Method)

at java.io.FileInputStream.open(FileInputStream.java:195)

at java.io.FileInputStream.<init>(FileInputStream.java:138)

at org.apache.hadoop.mapred.uploader.FrameworkUploader.buildPackage(FrameworkUploader.java:339)

at org.apache.hadoop.mapred.uploader.FrameworkUploader.run(FrameworkUploader.java:126)

at org.apache.hadoop.mapred.uploader.FrameworkUploader.main(FrameworkUploader.java:610)

Exception in thread "main" java.lang.RuntimeException: java.io.FileNotFoundException: /opt/cloudera/parcels/CDH-7.1.9-1.cdh7.1.9.p1000.55406660/lib/hadoop/./ozone-filesystem-hadoop3-1.4.0.7.1.9.1000-103.jar (Permission denied)

at org.apache.hadoop.mapred.uploader.FrameworkUploader.run(FrameworkUploader.java:136)

at org.apache.hadoop.mapred.uploader.FrameworkUploader.main(FrameworkUploader.java:610)

Caused by: java.io.FileNotFoundException: /opt/cloudera/parcels/CDH-7.1.9-1.cdh7.1.9.p1000.55406660/lib/hadoop/./ozone-filesystem-hadoop3-1.4.0.7.1.9.1000-103.jar (Permission denied)

at java.io.FileInputStream.open0(Native Method)

at java.io.FileInputStream.open(FileInputStream.java:195)

at java.io.FileInputStream.<init>(FileInputStream.java:138)

at org.apache.hadoop.mapred.uploader.FrameworkUploader.buildPackage(FrameworkUploader.java:339)

at org.apache.hadoop.mapred.uploader.FrameworkUploader.run(FrameworkUploader.java:126)

1 ACCEPTED SOLUTION

avatar
Expert Contributor

Hi @jshng,
Thank you for reaching out to Cloudera community

It appears that you are encountering the known issue OPSAPS-67607, as described in the Cloudera documentation[1].

On all nodes where the issue is observed, please run the following commands:

sudo mkdir /var/lib/hadoop-hdfs/
sudo chown hdfs:hadoop /var/lib/hadoop-hdfs/
sudo chmod 755 /var/lib/hadoop-hdfs/

Once the directory /var/lib/hadoop-hdfs/ has been created and permissions are set, please proceed with deactivating and reactivating the CDP parcel.

Let us know if this resolves the issue. For additional reference, you may also consult the following TSB article which outlines the same steps [2].

[1] - https://docs.cloudera.com/cdp-private-cloud-base/7.1.9/runtime-release-notes/topics/rt-pvc-known-iss...

[2] - https://lighthouse.cloudera.com/s/article/TSB-2024-775-FileNotFoundException-for-Ozone-FS-JAR-during...

Regards,
JP

 

View solution in original post

4 REPLIES 4

avatar
Expert Contributor

Hi @jshng,
Thank you for reaching out to Cloudera community

It appears that you are encountering the known issue OPSAPS-67607, as described in the Cloudera documentation[1].

On all nodes where the issue is observed, please run the following commands:

sudo mkdir /var/lib/hadoop-hdfs/
sudo chown hdfs:hadoop /var/lib/hadoop-hdfs/
sudo chmod 755 /var/lib/hadoop-hdfs/

Once the directory /var/lib/hadoop-hdfs/ has been created and permissions are set, please proceed with deactivating and reactivating the CDP parcel.

Let us know if this resolves the issue. For additional reference, you may also consult the following TSB article which outlines the same steps [2].

[1] - https://docs.cloudera.com/cdp-private-cloud-base/7.1.9/runtime-release-notes/topics/rt-pvc-known-iss...

[2] - https://lighthouse.cloudera.com/s/article/TSB-2024-775-FileNotFoundException-for-Ozone-FS-JAR-during...

Regards,
JP

 

avatar
Frequent Visitor

Hi @ymprakash, thank you for the prompt response. However I'm unable to access your [2] URL where it requires an Enterprise Subscription. My customer do have the subscription but not tied to my account. Appreciate if you or anyone could extract for me.

Otherwise I'll follow your advice and create the required folders and permission come Monday onsite.

Thank you very much once again.

avatar
Expert Contributor

Hi @jshng The KB has the same steps which in mentioned in my last comment.I just added the link for your reference.

Regards,
JP

avatar
Frequent Visitor

Hi @ymprakash, noted and thank you very much. I managed to solve using the steps you provided. Kudos to you!