Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Error adding new queue using YARN Queue Manager UI

avatar
New Contributor

Attempting to add a new queue using YARN Queue Manager UI.  After saving, the following error message appears:

 

Validation failed for Add queue operation! Error message:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<RemoteException>

    <exception>AuthorizationException</exception>

    <message>Unable to obtain user name, user not authenticated</message>

    <javaClassName>org.apache.hadoop.security.authorize.AuthorizationException</javaClassName>

</RemoteException>

 

Environment:  CDP DC 7.1.4
Kerberized:  Yes

TLS:  No

LDAP/AD:  Yes

 

Checked Ranger logs and Audit logs, Yarn RM and security logs.  Couldn't find any related errors in those log files.  The Ranger Audit logs show the user accessing the YARN queue but does not show a denied result.  There are LDAP/AD related errors in Usersync...would that cause authentication issues for YARN Queue Manager?

1 ACCEPTED SOLUTION

avatar
New Contributor

The following property was removed and the error went away.  Able to add YARN queues in the UI now.

hadoop.http.filter.initializers

 

View solution in original post

2 REPLIES 2

avatar
New Contributor

The following property was removed and the error went away.  Able to add YARN queues in the UI now.

hadoop.http.filter.initializers

 

avatar
Contributor

you property was removed, removed from what/where? I cannot find it.