Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Error in RedHat7 when trying to install ambari-server.

avatar
Contributor

I have a problem with the installation of ambari-server when I put the command: "yum install ambari-server".

The error I get is the next:

"This system is registered to Red Hat Subscription Management, but is not receiving updates. You can use subscription-manager to assign subscriptions.

Resolviendo dependencias

--> Ejecutando prueba de transacción

---> Paquete ambari-server.x86_64 0:2.4.0.1-1 debe ser instalado

--> Procesando dependencias: postgresql-server >= 8.1 para el paquete: ambari-server-2.4.0.1-1.x86_64

--> Resolución de dependencias finalizada Error: Paquete: ambari-server-2.4.0.1-1.x86_64 (Updates-ambari-2.4.0.1) Necesita: postgresql-server >= 8.1

Podría intentar utilizar el comando --skip-broken para sortear el problema

Podría intentar ejecutar: rpm- Va --nofiles --nodigest"

What can I do?

1 ACCEPTED SOLUTION

avatar
Rising Star
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
3 REPLIES 3

avatar

@pfctic2 pfctic2

Are you able to run the following command without any error?

yum update

Is your system is properly registered to the redhat subscription manager? https://access.redhat.com/solutions/1213413

- What does the following command show ?

yum repolist all

yum whatprovides postgresql

avatar
Contributor

When I run the command yum update I a message that says: "This system is registered to Red Hat Subscription Management, but is not receiving updates. You can use subscription-manager to assign subscriptions."

avatar
Rising Star
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login