Support Questions
Find answers, ask questions, and share your expertise

Error saving workflow to Oozie: HTTP Error 401 Auth failure

Explorer

Hi all,

I've set up a new instance of HDP 2.6. I've also added the Workflow Manager view to be able to add workflows/coordinator jobs to Oozie easily. However when I submit a Workflow to Oozie in the Workflow Manager view, I only get the following error message:

Error occurred while saving workflow
Submitting job to Oozie failed. Please check your definition/configuration.

HTTP Status 401 -

description This request requires HTTP authentication.
Apache Tomcat/6.0.48

    at org.apache.oozie.ambari.view.OozieDelegate.submitWorkflowJobToOozie(OozieDelegate.java:104)
    at org.apache.oozie.ambari.view.OozieProxyImpersonator.submitJob(OozieProxyImpersonator.java:208)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) 
[...]

Do I need to enter some username/password somewhere...? I did not see any setting for this in the workflow manager?

Regards

Frank

1 ACCEPTED SOLUTION

Accepted Solutions

Explorer

I managed to fix it myself 🙂 looks like the reverse DNS lookup does/did not work correctly in my virtual machine which I used for testing. Setting the config setting hadoop.proxyuser.oozie.hosts to * (for testing!) fixed the problem (before it was the hostname). I guess this had to with the IP address 127.0.0.1 being mapped to localhost and not to the hostname of my machine, which is mapped to 127.0.1.1.

View solution in original post

1 REPLY 1

Explorer

I managed to fix it myself 🙂 looks like the reverse DNS lookup does/did not work correctly in my virtual machine which I used for testing. Setting the config setting hadoop.proxyuser.oozie.hosts to * (for testing!) fixed the problem (before it was the hostname). I guess this had to with the IP address 127.0.0.1 being mapped to localhost and not to the hostname of my machine, which is mapped to 127.0.1.1.

View solution in original post