Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Error storing data "Row key not found"

avatar
New Member

Hello,

After 13th January, all my store streamsets stopped storing data with an error similar like this below.

We are collecting data from ETW and IIS log data, that is first collect, then transform, and finally store. This last step is falling.

Can someone help?

 

KUDU_15 - Row key '(string id="3d755d2d-949e-4fba-9925-63f658b44773", int32 year=2020, int32 month=2, int32 day=21, string host="vipe-exch03", string type="etw", string environment="prod", string groupid="iis")' not found

-----------------------------------

1 ACCEPTED SOLUTION

avatar
New Member

Just found what the problem was. The table was divided in partitions by months and some tables reached the already monthly pré-created partitions. The resolution passed by creating new partitions and the data started to by stored again.

View solution in original post

3 REPLIES 3

avatar
Visitor

Are you a StreamSets customer? If so, you should open a support ticket.

avatar
Visitor

Looking at the error, it seems like you're trying to process an insert as an update. Check the logic of your pipeline. If it was working before, something must have changed.

avatar
New Member

Just found what the problem was. The table was divided in partitions by months and some tables reached the already monthly pré-created partitions. The resolution passed by creating new partitions and the data started to by stored again.