Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 06-05-2025 12:23 AM
Hello community,
I have a PowerBi application with some dashboards. The dashboards are updated according to the configuration at least 2 times a day. The dashboards connected to Impala sometimes do not update and I get this error (see below). It does not happen all the time but many times. I have to update it manually every time I get the error. I use cloudera ODBC driver (64 bit) and basic gateway (PowerBi Cloud): on-premise data gateway.
Can you help me to solve the update problems?
Thank you,
Translated with DeepL.com (free version)
Error message:
Created 06-05-2025 01:40 PM
Hello-
The error you have provided:
"ODBC: ERROR [HY000] [Microsoft][DriverSupport] (1170) Unexpected response received from server. Please ensure the server host and port specified for the connection are correct."
- is quite obscure. The following could cause it:
a. outdated ODBC Driver
b. intermittent network issue
c. misconfigured or malfunctioning Load Balancer.
d. invalid certificate(s) on one or few Impala coordinators (behind the Load Balancer).
- each of the above or some combination of those.
In order for us to help you with troubleshooting, please open a case with Cloudera Support.
Thank you.
Created 06-05-2025 12:55 PM
@AnaIsabel Welcome to the Cloudera Community!
To help you get the best possible solution, I have tagged our Impala experts @jAnshula @Boris G @Saurabhatiyal who may be able to assist you further.
Please keep us updated on your post, and we hope you find a satisfactory solution to your query.
Regards,
Diana Torres,Created 06-05-2025 01:40 PM
Hello-
The error you have provided:
"ODBC: ERROR [HY000] [Microsoft][DriverSupport] (1170) Unexpected response received from server. Please ensure the server host and port specified for the connection are correct."
- is quite obscure. The following could cause it:
a. outdated ODBC Driver
b. intermittent network issue
c. misconfigured or malfunctioning Load Balancer.
d. invalid certificate(s) on one or few Impala coordinators (behind the Load Balancer).
- each of the above or some combination of those.
In order for us to help you with troubleshooting, please open a case with Cloudera Support.
Thank you.