Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Error when updating Power BI connected to Impala with Cloudera ODBC Driver for Impala

avatar

Hello community,

I have a PowerBi application with some dashboards. The dashboards are updated according to the configuration at least 2 times a day. The dashboards connected to Impala sometimes do not update and I get this error (see below). It does not happen all the time but many times. I have to update it manually every time I get the error. I use cloudera ODBC driver (64 bit) and basic gateway (PowerBi Cloud): on-premise data gateway.

Can you help me to solve the update problems?

Thank you,

Translated with DeepL.com (free version)

Error message:  

  • {"error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","pbi.error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","parameters":{},"details":[{"code":"DM_ErrorDetailNameCode_UnderlyingErrorCode","detail":{"type":1,"value":"-2147467259"}}, {"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"ODBC: ERROR [HY000] [Microsoft][DriverSupport] (1170) Unexpected response received from server. Please ensure the server host and port specified for the connection are correct."}},{"code":"DM_ErrorDetailNameCode_UnderlyingHResult","detail":{"type":1,"value":"-2147467259"}},{"code":"Microsoft.Data.Mashup.ErrorCode","detail":{"type":1,"value":"10478"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourceKind","detail":{"type":1,"value":"Impala"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourcePath","detail":{"type":1,"value":"md-iplb-rbap.emea.bosch.com:21050"}},{"code":"Microsoft.Data.Mashup.ValueError.OdbcErrors","detail":{"type":1,"value":"#table({\"SQLState\", \"NativeError\", \"Message\"}, {})"}},{"code":"Microsoft.Data.Mashup.ValueError.Reason","detail":{"type":1,"value":"DataSource.Error"}}],"exceptionCulprit":1}}} Table: qmm_process_uss5_fermasilb_batch.URI de clústerWABI-NORTH-EUROPE-L-PRIMARY-redirect.analysis.windows.net
1 ACCEPTED SOLUTION

avatar
Expert Contributor

Hello-

The error you have provided:

 

"ODBC: ERROR [HY000] [Microsoft][DriverSupport] (1170) Unexpected response received from server. Please ensure the server host and port specified for the connection are correct."

- is quite obscure. The following could cause it:

 

a. outdated ODBC Driver

b. intermittent network issue

c. misconfigured or malfunctioning Load Balancer.

d. invalid certificate(s) on one or few Impala coordinators (behind the Load Balancer).


- each of the above or some combination of those.

 

In order for us to help you with troubleshooting, please open a case with Cloudera Support.

 

Thank you.

View solution in original post

2 REPLIES 2

avatar
Community Manager

@AnaIsabel Welcome to the Cloudera Community!

To help you get the best possible solution, I have tagged our Impala experts @jAnshula @Boris G @Saurabhatiyal  who may be able to assist you further.

Please keep us updated on your post, and we hope you find a satisfactory solution to your query.


Regards,

Diana Torres,
Senior Community Moderator


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:

avatar
Expert Contributor

Hello-

The error you have provided:

 

"ODBC: ERROR [HY000] [Microsoft][DriverSupport] (1170) Unexpected response received from server. Please ensure the server host and port specified for the connection are correct."

- is quite obscure. The following could cause it:

 

a. outdated ODBC Driver

b. intermittent network issue

c. misconfigured or malfunctioning Load Balancer.

d. invalid certificate(s) on one or few Impala coordinators (behind the Load Balancer).


- each of the above or some combination of those.

 

In order for us to help you with troubleshooting, please open a case with Cloudera Support.

 

Thank you.