Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Exercise 1: Apache sqoop errors with "expected numeric argument."

SOLVED Go to solution

Exercise 1: Apache sqoop errors with "expected numeric argument."

New Contributor

I am following the steps in Exercise 1. Apache sqoop errors with "expected numeric argument." . Assistance will be much appreciated. Below is more information.

 

[ec2-user@cloudera1 ~]$ sqoop import-all-tables -m {{cluster_data.worker_node_hostname.length}} --connect jdbc:mysql://{{cluster_data.manager_node_hostname}}:3306/retail_db --username=retail_dba --password=cloudera --compression-codec=snappy --as-parquetfile --warehouse-dir=/user/hive/warehouse --hive-import

Warning: /opt/cloudera/parcels/CDH-5.4.2-1.cdh5.4.2.p0.2/bin/../lib/sqoop/../accumulo does not exist! Accumulo imports will fail.

Please set $ACCUMULO_HOME to the root of your Accumulo installation.

16/01/02 11:48:23 INFO sqoop.Sqoop: Running Sqoop version: 1.4.5-cdh5.4.2

16/01/02 11:48:23 WARN tool.BaseSqoopTool: Setting your password on the command-line is insecure. Consider using -P instead.

Error: expected numeric argument.

Try --help for usage.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Exercise 1: Apache sqoop errors with "expected numeric argument."

New Contributor
1 REPLY 1
Highlighted

Re: Exercise 1: Apache sqoop errors with "expected numeric argument."

New Contributor