Support Questions
Find answers, ask questions, and share your expertise

Exhausted available authentication methods error

New Contributor

We tried with root user and with test user also, but still getting the above error. 

We also did below config change for root user

  • sudo vi /etc/ssh/sshd_config

Search and change the below lines as below,

  • PermitRootLogin yes
  • sudo systemctl restart sshd

 

For test user, we did below config change

sudo vi /etc/sudoers

added below line

ec2-user ALL=(ALL)  ALL

However, with doing the the above changes we are not able to login with both root and test user. Can you please help us on this

1 ACCEPTED SOLUTION

Master Collaborator

From the extension of your key file (key.ppk), my guess is that you're using PuTTY to connect to the VMs. Is that correct?

 

PuTTY uses a different key format than OpenSSH clients. If the above is correct, try converting your key.ppk to OpenSSH format using PuTTYgen (see link below) and try again using the converted file.

 

https://www.thegeekdiary.com/how-to-convert-puttys-private-key-ppk-to-ssh-key/

 

Cheers,

André

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

View solution in original post

8 REPLIES 8

Master Collaborator

Is this related to CDP? Where is your environment?

Without the context we can't help.

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

New Contributor
Yes. It is related to CDP. Environment is hosted in AWS.

New Contributor

yes..this is related to CDP. Environment is hosted in AWS

Master Collaborator

Is this a CDP Data Hub?

How did you create the VM?

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

New Contributor

We created the VM manually through portal. We installed the CDP manager and completed pre-requistes and now we are setting up the cluster through UI, where it is throwing this error. Refer attached screenshot for same. Let me know in case you need more info on this.cdpclustererror.PNG

Master Collaborator

Thanks. The context of it is much clearer now.

Could you also provide a screenshot of the Login Credentials page of the wizard?

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

New Contributor

PFA same. I have tried with both root and test user.Using both key and passwordlogin1.PNGlogin2.PNG

Master Collaborator

From the extension of your key file (key.ppk), my guess is that you're using PuTTY to connect to the VMs. Is that correct?

 

PuTTY uses a different key format than OpenSSH clients. If the above is correct, try converting your key.ppk to OpenSSH format using PuTTYgen (see link below) and try again using the converted file.

 

https://www.thegeekdiary.com/how-to-convert-puttys-private-key-ppk-to-ssh-key/

 

Cheers,

André

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.