Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Exhausted available authentication methods

Highlighted

Exhausted available authentication methods

Hi,

 

I am trying to install Cloudera using root user as login user and SSH port 22 but and localhost for IP Adress and I am getting the error : "Installation failed". Failed to autheticate, details: "Exhausted available authentication methods".

 

Could you please tell me how can I solve the issue?

 

Thanks a lot,

Regards,

9 REPLIES 9

Re: Exhausted available authentication methods

Champion

This could be of two reason, one is the mis match of RSA public / private keys in the master / slave nodes

check their 

 

permission
owner 
like 
chmod 
chown 
id_rsa
authorized_keys
id_rsa.pub

 

Reason 2 . 

 

Check your iptable / Firewall settings 

 - see if it is up and runining or not 

 

Reason 3

check the /etc/hosts files in all the node 
check the /etc/sysconfig/network
hostname

Please let me know if that helps or not .we should be able to troubleshoot .

I resolved this error a couple of weeks back. 

 

 

 

Re: Exhausted available authentication methods

Thanks, Could you please specifiy how to check the iptable and which are the parameters I should have?
Thanks a lot,
Regards

Re: Exhausted available authentication methods

How can I know the IP that I have to set in the host file? Thanks!

Re: Exhausted available authentication methods

Champion

What configurations are you going peform

single node cluster or multi node cluster .

 

Usually can define your own ip for your hosts like below for example

 

in the /etc/hosts file using vi editor

 

master 192.168.200.221
slave1  192.168.200.222
slave2   192.168.200.223

Re: Exhausted available authentication methods

This is quite common issue while installing CDH.However it is so easy to resolve it.

 

This is the issue with ssh.

You need to edit the  /etc/ssh/sshd_config   file by changing below parameter :-

 

PermitRootLogin yes

 

Now restart ssh service : sudo service ssh restart

 

Now Select root to login as below

 

Screenshot from 2019-05-20 21-28-52.png

 

click on Continue

 

Your issue will be resolved.

 

Thanks,

Solomonchinni

Re: Exhausted available authentication methods

Champion
systemctl status firewalld

if you see active then your firewall is ON.

 

to switch off the Firewall perform

 

systemctl stop firewalld

finally perform this to disable even during boot of your operating system

 

systemctl disable firewalld

Re: Exhausted available authentication methods

Contributor

There must be a problem with your ssh-keys.
1. Generate ssh-key (public and private)
2. Copy id_rsa.pub content to authorized_keys
3. Change authorized_keys permissions to 600
4. Copy the id_ras.pub key content to the other nodes authorized_keys

Then try again

 

P.S: It will work only, when you use associated used with above keys

Re: Exhausted available authentication methods

Thanks, I have already done this task twice and the status is exactly the same. Is there a way to know which is the IP that I have to set in the IP file?
Thanks again,

Re: Exhausted available authentication methods

Contributor
IP file..?
If it is regarding iptables. You can check this by doing "iptables -L" as root.

Note: Firewall and iptables should be disabled while installing CDH