Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Grafana HBase-Performance -> Operation Latencies -Scan Next shows 'No datapoints'

Solved Go to solution
Highlighted

Grafana HBase-Performance -> Operation Latencies -Scan Next shows 'No datapoints'

Ambari: 2.2.2

HDP : 2.4.2

Why do only these graphs show No datapoints?

13122-screen-shot-2017-02-28-at-20955-pm.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Grafana HBase-Performance -> Operation Latencies -Scan Next shows 'No datapoints'

Expert Contributor

Are you able to see other RegionServer metrics on this dashboard?

I checked out my test cluster with HDP 2.6 and Ambari 2.5 and I am able to see them.

One way to verify if these metrics were ever sent to AMS is by making a call to AMS metadata API in your browser:

http://<ams-collector-host>:6188/ws/v1/timeline/metrics/metadata

You can look for metrics name in the response, example: regionserver.Server.ScanTime

View solution in original post

3 REPLIES 3

Re: Grafana HBase-Performance -> Operation Latencies -Scan Next shows 'No datapoints'

Expert Contributor

Are you able to see other RegionServer metrics on this dashboard?

I checked out my test cluster with HDP 2.6 and Ambari 2.5 and I am able to see them.

One way to verify if these metrics were ever sent to AMS is by making a call to AMS metadata API in your browser:

http://<ams-collector-host>:6188/ws/v1/timeline/metrics/metadata

You can look for metrics name in the response, example: regionserver.Server.ScanTime

View solution in original post

Highlighted

Re: Grafana HBase-Performance -> Operation Latencies -Scan Next shows 'No datapoints'

@swagle

Yes I can see other HBase metrics.

http://hdp242-s1.openstacklocal:3000/dashboard/db/hbase-performance

I do not see "regionserver.Server.ScanTime" in the metadata.

ambarimetrics-metadata.txt

Highlighted

Re: Grafana HBase-Performance -> Operation Latencies -Scan Next shows 'No datapoints'

Expert Contributor

hdp242-s1.openstacklocal: Doesn't resolve for me.

If the metric is not in metadata that means that HBase has never sent this metric to AMS.

Did you perform a scan / run Ambari Smoke test to see if any data is sent?

Could be this metric is not sent by the HBase version you are using?

Don't have an account?
Coming from Hortonworks? Activate your account here