Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HBASE replication add_peer giving NoAuth error Kerberized clusters with same realm two different service ids

Solved Go to solution

HBASE replication add_peer giving NoAuth error Kerberized clusters with same realm two different service ids

Contributor

hbase(main):002:0> add_peer '1',"zknode1,zknode2,zknode3:2181/hbase-secure"

ERROR: KeeperErrorCode = NoAuth for /hbase-secure/replication/peers

Here is some help for this command: A peer can either be another HBase cluster or a custom replication endpoint. In either case an id must be specified to identify the peer.

Background:

hbase(Dev Cluster) with service id dev-hbase --> hbase(QA Cluster) with service id qa-hbase.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: HBASE replication add_peer giving NoAuth error Kerberized clusters with same realm two different service ids

Guru

You are probably running into https://issues.apache.org/jira/browse/HBASE-1514.

In secure clusters, you should run the zkcli command with --auth-as-server parameter. Like this:

hbase --auth-as-server zkcli 

In newer versions of HDP, the patch should be there. Otherwise, you can get this working with something like:

HBASE_OPTS="$HBASE_OPTS -Djava.security.auth.login.config=/usr/hdp/current/hbase-regionserver/conf/hbase_master_jaas.conf hbase zkcli 

Please note that the jaas.conf file that you add to the HBASE_OPTS before running the zkcli command should match what you have for your master and regionservers.

2 REPLIES 2
Highlighted

Re: HBASE replication add_peer giving NoAuth error Kerberized clusters with same realm two different service ids

Guru

You are probably running into https://issues.apache.org/jira/browse/HBASE-1514.

In secure clusters, you should run the zkcli command with --auth-as-server parameter. Like this:

hbase --auth-as-server zkcli 

In newer versions of HDP, the patch should be there. Otherwise, you can get this working with something like:

HBASE_OPTS="$HBASE_OPTS -Djava.security.auth.login.config=/usr/hdp/current/hbase-regionserver/conf/hbase_master_jaas.conf hbase zkcli 

Please note that the jaas.conf file that you add to the HBASE_OPTS before running the zkcli command should match what you have for your master and regionservers.

Re: HBASE replication add_peer giving NoAuth error Kerberized clusters with same realm two different service ids

Contributor