Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

HDFS_CANARY_HEALTH Failure and "Cannot create a file. Namenode in safe mode" in NameNode HA

avatar
Visitor

I have seen a situation wher some of the jobs suddenly failed with error saying "Cannot create a file. Namenode in safe mode." When I check the cloudera manager, HDFS_CANARY_HEALTH check failed. I also observed that the Active namenode become standaby and standby become active. So, if the HDFS_CANARY_HEALTH test fails then Namenode restarts by itself? Can anyone respond to this.

1 ACCEPTED SOLUTION

avatar
The canary test does not have anything with the failover. This just reports to the Cloudera Manager the health status. The actual failover in HA scenario is initiated by a Failover controller(s) - you have probably two NN, 3 (or 5) JNodes and Failover controllers. When the Active NN goes down, the FC brings the standby NN into a Active mode

View solution in original post

1 REPLY 1

avatar
The canary test does not have anything with the failover. This just reports to the Cloudera Manager the health status. The actual failover in HA scenario is initiated by a Failover controller(s) - you have probably two NN, 3 (or 5) JNodes and Failover controllers. When the Active NN goes down, the FC brings the standby NN into a Active mode