Support Questions
Find answers, ask questions, and share your expertise

HDP 2.3 to 2.5 Rolling Upgrade MySQL Requirements

Solved Go to solution

HDP 2.3 to 2.5 Rolling Upgrade MySQL Requirements

Expert Contributor

Hi,

I am upgrading my cluster since HDP 2.1. I used there MySQL version 5.1. Now I am going to upgrade HDP 2.3 to 2.5 using Express Upgrade. During install of HDP 2.5 packages I got an error that some mysql packages require mysql-community-common and devel of version 5.7.9. There is nothing about MySQL upgrade is required in the documentation. My question is: does HDP 2.5 contains and upgrades MySQL? and which version of MySQL do I need to have before upgrade?

I am using MySQL for Ranger and Hive Metastore.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: HDP 2.3 to 2.5 Rolling Upgrade MySQL Requirements

Expert Contributor

@Artem Ervits

Thanks for the answer.

Actually the problem has gone, because I downgraded MySQL to version 5.7.9 (which was required) from 5.7.13. The problem was about requirements, Ambari needed mysql-community-common and devel of version 5.7.9.

View solution in original post

3 REPLIES 3

Re: HDP 2.3 to 2.5 Rolling Upgrade MySQL Requirements

Mentor
@Edgar Daeds

you're required to have MySQL 5.1 and up https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.5.0/bk_release-notes/content/ch01s02s03.html

HDP upgrade does not upgrade MySQL for you. Consider providing the error log for us to help debug your issues.

Re: HDP 2.3 to 2.5 Rolling Upgrade MySQL Requirements

Expert Contributor

@Artem Ervits

Thanks for the answer.

Actually the problem has gone, because I downgraded MySQL to version 5.7.9 (which was required) from 5.7.13. The problem was about requirements, Ambari needed mysql-community-common and devel of version 5.7.9.

View solution in original post

Re: HDP 2.3 to 2.5 Rolling Upgrade MySQL Requirements

Mentor

@Edgar Daeds glad you got it resolved and provided solution. Thank you