Support Questions
Find answers, ask questions, and share your expertise

HDP 2.5.3 install failing on Redhat 7

Solved Go to solution
Highlighted

HDP 2.5.3 install failing on Redhat 7

Super Guru

I have tried to install HDP 2.5.3 on redhat 7 (aws) and it has failed due to error below:

2017-03-01 22:41:38,450 - Execution of '/usr/bin/yum -d 0 -e 0 -y install snappy-devel' returned 1. Error: Package: snappy-devel-1.0.5-1.el6.x86_64 (HDP-UTILS-1.1.0.21)
           Requires: snappy(x86-64) = 1.0.5-1.el6
           Installed: snappy-1.1.0-3.el7.x86_64 (@anaconda/7.3)
               snappy(x86-64) = 1.1.0-3.el7
           Available: snappy-1.0.5-1.el6.x86_64 (HDP-UTILS-1.1.0.21)
               snappy(x86-64) = 1.0.5-1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

The work around is to uninstall snappy-1.1.0-3.el7.x86_64

sudo yum remove snappy-1.1.0-3.el7.x86_64

and then install correct package

sudo yum install snappy-devel-1.0.5-1.el6.x86_64

then retry services install (ie data node)

Is this known issue?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: HDP 2.5.3 install failing on Redhat 7

Super Mentor

@Sunile Manjee

I see it in ambari 2.4.2 docs as well:

http://docs.hortonworks.com/HDPDocuments/Ambari-2.4.2.0/bk_ambari-troubleshooting/content/resolving_...

"3.10. Problem: DataNode Fails to Install on RHEL/CentOS 7" The explanation of this section makes sense "Hadoop requires the snappy-devel package that is a lower version that what is on the machine already. Run the following on the host and retry."

View solution in original post

4 REPLIES 4
Highlighted

Re: HDP 2.5.3 install failing on Redhat 7

Super Mentor

@Sunile Manjee

There are some known issues reported for older version of ambari (like 2.2.2) to resolve the "snappy-devel" conflict. That seems to be true even for the later version (Specially CentOS7/RHEL7):

http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.2.0/bk_ambari_troubleshooting/content/_resolving...

Hadoop requires the snappy-devel package that is a lower version that what is on the machine already. Run the following on the host and retry.

# yum remove snappy
# yum install snappy-devel
Highlighted

Re: HDP 2.5.3 install failing on Redhat 7

Super Guru

this is using ambari 2.4.2

Highlighted

Re: HDP 2.5.3 install failing on Redhat 7

Super Mentor

@Sunile Manjee

I see it in ambari 2.4.2 docs as well:

http://docs.hortonworks.com/HDPDocuments/Ambari-2.4.2.0/bk_ambari-troubleshooting/content/resolving_...

"3.10. Problem: DataNode Fails to Install on RHEL/CentOS 7" The explanation of this section makes sense "Hadoop requires the snappy-devel package that is a lower version that what is on the machine already. Run the following on the host and retry."

View solution in original post

Re: HDP 2.5.3 install failing on Redhat 7

Hi Sunile,

As we discussed yesterday, I found this installing HDP 2.5.3 using Ambari 2.4.2. Looking further into this, RHEL 7.3 comes installed with snappy 1.1.0-3.el7 while HDP 2.5.3 needs snappy 1.0.5-1.el6.x86_64. I spun up a RHEL 7.3 instance and ran the following command, showing snappy 1.1.0-3.el7 came pre-installed:

13174-screen-shot-2017-03-02-at-91647-am.png

As Jay posted - Looking at the latest documentation for Ambari 2.4.2, I found this problem in "Resolving Cluster Deployment Problems" - there should be a bug fix that goes into RHEL 7 (so we don't rely on a rhel 6 dependency) https://docs.hortonworks.com/HDPDocuments/Ambari-2.4.2.0/bk_ambari-troubleshooting/content/resolving...

- What do you think?

Don't have an account?