Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
10-04-2019
07:13 AM
- last edited on
10-04-2019
02:31 PM
by
ask_bill_brooks
I have newly imported HDP 2.6.5 Sandbox after removing the 2.6.4, and tried to connect via ssh. My host machine Windows 10. My command:
ssh [email protected] -p 2222
The error output:
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
SHA256:8F0VOvcJIA2FD3Ld90kv5FiD3270onl/+uDeDBNffQ0.
Please contact your system administrator.
Add correct host key in /c/Users/user/.ssh/known_hosts to get rid of this message.
Offending RSA key in /c/Users/user/.ssh/known_hosts:3
RSA host key for [sandbox-hdp.hortonworks.com]:2222 has changed and you have requested strict checking.
Host key verification failed.
Created 10-04-2019 12:24 PM
It seems you have an issue with your known_hosts file, you need to remove the third(3) line in known_hosts file /c/Users/user/.ssh/known_hosts:3 Most likely an SSH altered the encryption keys due to a possible security hole. You can then purge that specific line from your known_hosts file:
# sed -i 377d ~/.ssh/known_hosts
but it seems your known_hosts file is mounted on the C drive on /c/Users/user/ windows 10!!
You can also remove StrictHostKey checking in your ssh configuration file, typically stored at ~/.ssh/config.
An example Host block is provided below:
Host 101
HostName yourip|hostname
User your_Userid
IdentityFile /path/to/keyfile
Port 22
StrictHostKeyChecking no
The specifically added line is the last one StrictHostKeyChecking no which does just that. Please do that and revert
Created 10-04-2019 12:24 PM
It seems you have an issue with your known_hosts file, you need to remove the third(3) line in known_hosts file /c/Users/user/.ssh/known_hosts:3 Most likely an SSH altered the encryption keys due to a possible security hole. You can then purge that specific line from your known_hosts file:
# sed -i 377d ~/.ssh/known_hosts
but it seems your known_hosts file is mounted on the C drive on /c/Users/user/ windows 10!!
You can also remove StrictHostKey checking in your ssh configuration file, typically stored at ~/.ssh/config.
An example Host block is provided below:
Host 101
HostName yourip|hostname
User your_Userid
IdentityFile /path/to/keyfile
Port 22
StrictHostKeyChecking no
The specifically added line is the last one StrictHostKeyChecking no which does just that. Please do that and revert
Created on 10-04-2019 12:51 PM - edited 10-04-2019 08:42 PM
Thank you @Shelton . I have just deleted the line specified in error message in
/c/Users/user/.ssh/known_hosts
It worked. I had used HDP 2.6.4 before this one. I think there was already a key for the same hostname, once delete it i was able to connect via ssh. This time added new key that belongs to HDP 2.6.5 Sandbox. In this case, Should I accept your solution? Because you offer additional solutions that I have not verified.
Created 10-05-2019 04:24 AM
Great !! it worked out for you, If you found this answer addressed your question, please take a moment to log in and click the thumbs up button.
That would be a great help to Cloudera Community to find the solution quickly for these kinds of errors and mark it as a solution