Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

HDP sandbox startup too long on virtualbox

New Contributor

when i started hdp 2.4 on my virtualbox in took way too long on startup i think it stopped after zepplin startup. My laptop have 6gb ram and I give 2gb ram on virtualbox. Can anyone help me with this problem?

14 REPLIES 14

Super Guru
@Muhammad Syamsudin

2gb ram for sandbox 2.4 is too less, as per recommendations we should at-least give 8GB of RAM.

https://hortonworks.com/wp-content/uploads/2015/05/Import_on_Vbox_5_11_2015.pdf

Expert Contributor

Long story short, you don't have enough RAM. The minimum recommendation is 8gb of RAM. Try running it with 4gb of RAM. I've gotten older version of HDP to start up with 4gb of RAM, though it was incredibly slow. If you can get it started with 4gb of RAM, you can navigate to Ambari and turn off alot of tools you don't want to use, and that should make the user experience a little better.

One other possible solution is if you are using a Windows machine, ensure that you have enabled your BIOS settings for virtualization. In order to do so, you will need to restart your computer and bring up the BIOS settings before the OS finishes loading (I think you need to hold f10, or f12 on start up). In the bios, look for device configuration. In that folder there should be a setting with the name like enable virtualization.

@Muhammad Syamsudin

Right as @Kuldeep Kulkarni mentioned. Please find some few more details on -

http://hortonworks.com/blog/announcing-sandbox-2-0/

EASY ENABLEMENT OF HBASE AND AMBARI
On the About Sandbox page in the Sandbox, you’ll find buttons to enable/disable Ambari and Hbase. We’ve shipped the Sandbox with these disabled to keep the memory requirements at the existing 4 Gb of physical RAM. In order to run Ambari or Hbase you’ll need to have 8Gb of of physical RAM and you’ll need to increase the memory allocation in your virtual machine to 4 Gb. If you have enough physical RAM, go ahead an increase the memory allocation to the VM and you’ll see a performance improvement.

Expert Contributor

@Muhammad Syamsudin, i'm getting the same issue.. did you fix the issue ?

Pls let me know the steps.

Hi All,

I have given 8GB ram, but still it takes so much of time to load. pls find the attached screen shot.

VM : Vmware

HDP : hdp2.6

34640-hdp26-loading.png

Explorer

Hi Gobi Subramani Have you had any help or solution on this. I am experiencing exactly the same problem as you.

New Contributor

Hi, my virtual machine get stuck on centos 7 startup screen and does not proceed further. screenshot attached.virtualbox-hortonworks-docker-sandbox-hdp-07-11-20.png

@Harish Ingle

Try opening a browser and navigating to http://localhost:8080

If Ambari opens up, then the sandbox has started fine and the VM screen has just not been refreshed (and can be safely ignored).

New Contributor

@Edgar Orendain @Harish Ingle

I am also facing the same issue. I have tried navigating to http://localhost:8080 and I am able to see Ambari. I have tried connecting through putty to 127.0.0.1 at port 2222 but I am unable to connect to hdfs. On checking the jps, I see not all hadoop daemons are running and I am getting the response as provided in the attached snapshot. I am using 16 GB RAM out of which 8911 MB is allocated to the VM. The Oracle Virtual Box version I am using is 5.1.30 r118389 (Qt5.6.2). The HDP version is 2.6.3.

hortonworks-errors.jpg.

Heya @Sai Manohar Boidapu

A few different suggestions to get the ball rolling:

1. Is the HFDS service and it's components shown as running from within Ambari? There should be a green checkmark next to HDFS and its components (Namenode, etc.)

2. If it is, could you then see if the namenode is up and running: ps -ef | grep -i namenode

New Contributor

Hi,

 

Have you been able to find the root cause for this error because i am facing the same problem.

New Contributor

@Edgar Orendain

Hi the link isn't opening.Browser says can't reach page

,

@Edgar Orendain

The link http://localhost:8080 isn't working either. I tried the link http://127.0.0.1:8888 as well with the same result. The browser says the page cant be reached in both cases.

@Harish Ingle

Would you happen to have the latest HDP Sandbox (HDP 2.6.3)? https://hortonworks.com/downloads/#sandbox

The version you have (2.5.x) should work as well, just mentioning in case you're interested.

That said, how much RAM is being allocated to the Sandbox? By default it should be requesting 8GB from VirtualBox, was this changed? Could you try SSH'ing into the sandbox (ssh root@localhost.com -p 2222) and if that doesn't work, then into the wrapping VM (ssh root@localhost -p 2122).

New Contributor

Hello all 

Please reply to this ASAP 

I am trying to install vm on my pc but my screen is sticking at the same point 

That Extracting and loading the hortonworks sandbox 

I have assigned 8 gb of ram n my laptop configuration is 8gb also and i5 n 7th gen