Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 01-15-2019 01:10 PM - edited 08-17-2019 03:01 PM
Hello,
When installing new HDP version in Ambari, the following error is displayed:
"Cluster <cluster_name> upgrade is in progress. Cannot install packages."
I had tried to use instruction like this
But not successfully. How can i work around this problem?
Created 01-16-2019 10:05 AM
My stupid mistake, i forgot what i had enabled manual commit in Dbeaver in production server and "upgrade_id" cell didn't update.
Created 01-15-2019 02:59 PM
Maybe is that problem because one item in last update was failed?
{
"href" : "http://*:8080/api/v1/clusters/DataLake/upgrades/865/upgrade_groups/434/upgrade_items/140",
"UpgradeItem" : {
"cluster_name" : "DataLake",
"command_params" : "{\"upgrade_pack\":\"nonrolling-upgrade-2.6\",\"clusterName\":\"DataLake\",\"upgrade_direction\":\"upgrade\",\"forceRefreshConfigTagsBeforeExecution\":\"true\",\"upgrade_type\":\"nonrolling_upgrade\",\"request_id\":\"865\"}",
"context" : "Save Cluster State",
"display_status" : "FAILED",
"end_time" : -1,
"group_id" : 434,
"host_params" : "{\"host_sys_prepped\":\"false\",\"agent_stack_retry_count\":\"5\",\"java_home\":\"/etc/alternatives/java_sdk\",\"jdk_location\":\"http://*.*.ru:8080/resources/\",\"stack_version\":\"2.6\",\"custom_postgres_jdbc_name\":\"postgresql-42.0.0.jar\",\"mysql_jdbc_url\":\"http://*:8080/resources//mysql-connector-java.jar\",\"oracle_jdbc_url\":\"http://*:8080/resources//ojdbc6.jar\",\"ambari_db_rca_password\":\"SECRET\",\"db_name\":\"ambari\",\"ambari_db_rca_driver\":\"org.postgresql.Driver\",\"ambari_db_rca_username\":\"ambari\",\"java_version\":\"8\",\"previous_custom_postgres_jdbc_name\":\"postgresql-42.0.0.jar\",\"not_managed_hdfs_path_list\":\"[\\\"/data/apps/hive/warehouse\\\",\\\"/data/app-logs\\\",\\\"/data/mr-history/done\\\",\\\"/tmp\\\"]\",\"db_driver_filename\":\"mysql-connector-java.jar\",\"gpl_license_accepted\":\"false\",\"agent_stack_retry_on_unavailability\":\"false\",\"ambari_db_rca_url\":\"jdbc:postgresql://*:5432/ambari\",\"stack_name\":\"HDP\"}",
"log_info" : null,
"progress_percent" : 100.0,
"request_id" : 865,
"skippable" : true,
"stage_id" : 140,
"start_time" : 1526474555466,
"status" : "COMPLETED",
"text" : "Save Cluster State"
},
"tasks" : [
{
"href" : "http://*:8080/api/v1/clusters/DataLake/upgrades/865/upgrade_groups/434/upgrade_items/140/tasks/11045",
"Tasks" : {
"cluster_name" : "DataLake",
"id" : 11045,
"request_id" : 865,
"stage_id" : 140
}
}
]
}
Created 01-16-2019 10:05 AM
My stupid mistake, i forgot what i had enabled manual commit in Dbeaver in production server and "upgrade_id" cell didn't update.