Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

HDP3 upgradation failed with check keytabs kerberos client failed

avatar
Rising Star

Hi Folks

I'm upgrading HDP 2.6.5 to 3.0.1, between i got below error "Check Keytabs Kerberos Client"

Caught an exception while executing custom service command: <type 'exceptions.Exception'>: Command requires configs with timestamp=1545289935876 but configs on agent have timestamp=1545289934256; Command requires configs with timestamp=1545289935876 but configs on agent have timestamp=1545289934256


I'm trying to find the issue. Please help me
1 ACCEPTED SOLUTION

avatar
Rising Star
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
3 REPLIES 3

avatar
Explorer

@Vinay

Could you please check your ambari-agent and ambari-server version.

check in database as well.

This issue occurs when there are incorrect entries present in the ambari database. The following is the table in the database. From the host_version

ambari=>select*from host_version;

Thanks,

Owez

avatar
Rising Star

Hi @Owez Mujawar

Ambari server and amabri agent version is 2.7.1.0-169.

Output of host_version is

ambari=> select * from host_version; id | repo_version_id | host_id | state -----+-----------------+---------+-----------

57 | 51 | 1 | CURRENT

56 | 51 | 7 | CURRENT

53 | 51 | 3 | CURRENT

55 | 51 | 4 | CURRENT

54 | 51 | 5 | CURRENT

52 | 51 | 6 | CURRENT

51 | 51 | 2 | CURRENT

avatar
Rising Star
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login