Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

HIVE don't display databases after re-creating cluster

avatar
New Contributor

Hi,

I've created hadoop cluster on Azure HDinsight, next I've created some databases on hive. After deleting and re-creating cluster with connection to the same storage account hive is not showing all databases by 'show databases;' command, I see only three default databases (default, information_schema,sys) even though the databases I've created are visible in hdfs.

1 ACCEPTED SOLUTION

avatar
Super Guru
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
3 REPLIES 3

avatar
Super Guru

@Damian_S If you have re-created the cluster,  did you migrate the original hive metastore data?  This metastore would have stored details about the hive tables in hdfs.   If you no longer have this metastore data, you will need to recreate the hive schemas/databases, and re-execute the hive table create statements against the hdfs files.   

 

If the metastore is intact (not recreated, reset, etc) then you may be experiencing permission issues against the files in hdfs.  

avatar
New Contributor

I haven't migrated the original metastore data. Is it possible to do this if I haven't put my metastore data outside the default database (I found information that by default metastore data is stored in derby database on the head node)? Or better way is to create some external database to keep metastore data and point the cluster to use this when re-creating?

avatar
Super Guru
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login