Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Hive - Replication issue through Cloudera Manager

avatar
Contributor

Hello Team,

 

We are setting the Hive replication through Cloudera Manager. The replication policy looks as follows.

Sayed016_0-1650383413614.png

 

Note that we also enabled the snapshot on the source cluster for the path - /warehouse

However, when we press save policy then we get the below notification.

 

Sayed016_1-1650383502561.png

 

We looked into the Cloudera Manager logs and we can see the below error. Can you please help us to get the correct configuration to resolve the issue?

2022-04-19 15:51:07,848 ERROR scm-web-1686:com.cloudera.server.web.cmf.WebController: getHiveWarehouseSnapshotsEnabled
javax.ws.rs.NotAuthorizedException: HTTP 401 Unauthorized
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
        at org.apache.cxf.jaxrs.client.AbstractClient.convertToWebApplicationException(AbstractClient.java:507)
        at org.apache.cxf.jaxrs.client.ClientProxyImpl.checkResponse(ClientProxyImpl.java:324)
        at org.apache.cxf.jaxrs.client.ClientProxyImpl.handleResponse(ClientProxyImpl.java:878)
        at org.apache.cxf.jaxrs.client.ClientProxyImpl.doChainedInvocation(ClientProxyImpl.java:791)
....
....
....
....
        at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:683)
        at java.lang.Thread.run(Thread.java:750)
2022-04-19 15:51:07,849 ERROR scm-web-1686:com.cloudera.server.web.common.JsonResponse: JsonResponse created with throwable: 
javax.ws.rs.NotAuthorizedException: HTTP 401 Unauthorized
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
        at org.apache.cxf.jaxrs.client.AbstractClient.convertToWebApplicationException(AbstractClient.java:507)
        at org.apache.cxf.jaxrs.client.ClientProxyImpl.checkResponse(ClientProxyImpl.java:324)
        at org.apache.cxf.jaxrs.client.ClientProxyImpl.handleResponse(ClientProxyImpl.java:878)
        at org.apache.cxf.jaxrs.client.ClientProxyImpl.doChainedInvocation(ClientProxyImpl.java:791)

 

 

 

 

 

1 ACCEPTED SOLUTION

avatar
Rising Star

@Sayed016 Thank you for your question.

From the error stack of CM logs, it looks like it tries to copy the system database and information_schema.

You need to exclude the system database and information_schema

Add the following exclusion on a Hive replication: Databases: (?!information_schema|sys\b).+ Tables: [\w].+ 

 

View solution in original post

2 REPLIES 2

avatar
Rising Star

@Sayed016 Thank you for your question.

From the error stack of CM logs, it looks like it tries to copy the system database and information_schema.

You need to exclude the system database and information_schema

Add the following exclusion on a Hive replication: Databases: (?!information_schema|sys\b).+ Tables: [\w].+ 

 

avatar
Contributor

@Bharati Thank you! This worked. However, could you please share which logs had shown that it was trying to copy the system database and information_schema?