Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Hive can not insert after enable HDFS Federation RBF

avatar
Explorer

when I enable HDFS Federation RBF, Hive tez job will throw error as follows:

 

hive-server2.log:

 

Caused by: org.apache.hadoop.hive.ql.metadata.HiveException: Hive Runtime Error while processing writable (null)

 

org.apache.hadoop.security.AccessControlException: Client cannot authenticate via:[TOKEN, KERBEROS]

 

I see https://issues.apache.org/jira/browse/TEZ-4032, and my tez version is 0.10.1,I didn't get any help from it.

 

Is there someone who can help me?

2 REPLIES 2

avatar
Master Collaborator

Hi @ken_zz 

I think it is a below known BUG, Fix versions is NONE.

https://issues.apache.org/jira/browse/HIVE-19689

 

Regards,

Chethan YM

avatar
Master Collaborator

If you suspect that TEZ-4032 is the cause, consider upgrading your cluster to CDP 7 and testing it again, as it has been backported in CDP 7.