Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HiveAccessControlException Permission denied: user [xxx] does not have [USE] privilege on

Solved Go to solution

HiveAccessControlException Permission denied: user [xxx] does not have [USE] privilege on

New Contributor

I'm encountering the following error while using beeline.  (Note that I'm able to successfully connect using hive cli.

 

[xxxx@ip-11-1-1-111 data_dir_design]$ beeline -u "jdbc:hive2://ip-11-1-1-111.us-west-1.compute.internal:10000/default;principal=hive/ip-11-1-1-111.us-west-1.compute.internal@EXAMPLE.COM"
Connecting to jdbc:hive2://ip-11-1-1-111.us-west-1.compute.internal:10000/default;principal=hive/ip-11-1-1-111.us-west-1.compute.internal@EXAMPLE.COM
Connected to: Apache Hive (version 1.2.1000.2.6.5.1175-1)
Driver: Hive JDBC (version 1.2.1000.2.6.5.1175-1)
Transaction isolation: TRANSACTION_REPEATABLE_READ
Beeline version 1.2.1000.2.6.5.1175-1 by Apache Hive
0: jdbc:hive2://ip-11-1-1-111.us-west-1.compu> show databases;
Error: Error while compiling statement: FAILED: HiveAccessControlException Permission denied: user [xxxx] does not have [USE] privilege on [Unknown resource!!] (state=42000,code=40000)
0: jdbc:hive2://ip-11-1-1-111.us-west-1.compu>

 

When connecting via hive:

[xxx@ip-11-1-1-111 data_dir_design]$ hive
log4j:WARN No such property [maxFileSize] in org.apache.log4j.DailyRollingFileAppender.

Logging initialized using configuration in file:/etc/hive/2.6.5.1175-1/0/hive-log4j.properties
hive> show databases;
OK
data
default
demo
Time taken: 0.971 seconds, Fetched: 3 row(s)
hive>

 

I have granted the proper permission in ranger.

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: HiveAccessControlException Permission denied: user [xxx] does not have [USE] privilege on

New Contributor

Disregard, fixed the issue by update Ranger Settings:

 

Ranger -> Advanced -> Ranger Settings: 

Updated External URL from public dns (using AWS) to Private DNS.

 

Restarted services and now beeline is working properly. 

View solution in original post

1 REPLY 1
Highlighted

Re: HiveAccessControlException Permission denied: user [xxx] does not have [USE] privilege on

New Contributor

Disregard, fixed the issue by update Ranger Settings:

 

Ranger -> Advanced -> Ranger Settings: 

Updated External URL from public dns (using AWS) to Private DNS.

 

Restarted services and now beeline is working properly. 

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here