Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 10-07-2020 09:48 AM - edited 10-07-2020 12:56 PM
I'm encountering the following error while using beeline. (Note that I'm able to successfully connect using hive cli.
[xxxx@ip-11-1-1-111 data_dir_design]$ beeline -u "jdbc:hive2://ip-11-1-1-111.us-west-1.compute.internal:10000/default;principal=hive/[email protected]"
Connecting to jdbc:hive2://ip-11-1-1-111.us-west-1.compute.internal:10000/default;principal=hive/[email protected]
Connected to: Apache Hive (version 1.2.1000.2.6.5.1175-1)
Driver: Hive JDBC (version 1.2.1000.2.6.5.1175-1)
Transaction isolation: TRANSACTION_REPEATABLE_READ
Beeline version 1.2.1000.2.6.5.1175-1 by Apache Hive
0: jdbc:hive2://ip-11-1-1-111.us-west-1.compu> show databases;
Error: Error while compiling statement: FAILED: HiveAccessControlException Permission denied: user [xxxx] does not have [USE] privilege on [Unknown resource!!] (state=42000,code=40000)
0: jdbc:hive2://ip-11-1-1-111.us-west-1.compu>
When connecting via hive:
[xxx@ip-11-1-1-111 data_dir_design]$ hive
log4j:WARN No such property [maxFileSize] in org.apache.log4j.DailyRollingFileAppender.
Logging initialized using configuration in file:/etc/hive/2.6.5.1175-1/0/hive-log4j.properties
hive> show databases;
OK
data
default
demo
Time taken: 0.971 seconds, Fetched: 3 row(s)
hive>
I have granted the proper permission in ranger.
Created 10-07-2020 01:27 PM
Disregard, fixed the issue by update Ranger Settings:
Ranger -> Advanced -> Ranger Settings:
Updated External URL from public dns (using AWS) to Private DNS.
Restarted services and now beeline is working properly.
Created 08-25-2021 01:07 AM
You need to provide ALL access to the User in the Ranger.
Please check the ranger permission settings in Ranger UI
Created 10-07-2020 01:27 PM
Disregard, fixed the issue by update Ranger Settings:
Ranger -> Advanced -> Ranger Settings:
Updated External URL from public dns (using AWS) to Private DNS.
Restarted services and now beeline is working properly.
Created 08-24-2021 04:53 PM
Hi, we are also running into same issue in CDP. Could you please let us know what exact configuration you changed to make it work..?
Thanks
Created 08-25-2021 01:07 AM
You need to provide ALL access to the User in the Ranger.
Please check the ranger permission settings in Ranger UI