Support Questions
Find answers, ask questions, and share your expertise

HiveAccessControlException Permission denied: user [xxx] does not have [USE] privilege on

New Contributor

I'm encountering the following error while using beeline.  (Note that I'm able to successfully connect using hive cli.

 

[xxxx@ip-11-1-1-111 data_dir_design]$ beeline -u "jdbc:hive2://ip-11-1-1-111.us-west-1.compute.internal:10000/default;principal=hive/ip-11-1-1-111.us-west-1.compute.internal@EXAMPLE.COM"
Connecting to jdbc:hive2://ip-11-1-1-111.us-west-1.compute.internal:10000/default;principal=hive/ip-11-1-1-111.us-west-1.compute.internal@EXAMPLE.COM
Connected to: Apache Hive (version 1.2.1000.2.6.5.1175-1)
Driver: Hive JDBC (version 1.2.1000.2.6.5.1175-1)
Transaction isolation: TRANSACTION_REPEATABLE_READ
Beeline version 1.2.1000.2.6.5.1175-1 by Apache Hive
0: jdbc:hive2://ip-11-1-1-111.us-west-1.compu> show databases;
Error: Error while compiling statement: FAILED: HiveAccessControlException Permission denied: user [xxxx] does not have [USE] privilege on [Unknown resource!!] (state=42000,code=40000)
0: jdbc:hive2://ip-11-1-1-111.us-west-1.compu>

 

When connecting via hive:

[xxx@ip-11-1-1-111 data_dir_design]$ hive
log4j:WARN No such property [maxFileSize] in org.apache.log4j.DailyRollingFileAppender.

Logging initialized using configuration in file:/etc/hive/2.6.5.1175-1/0/hive-log4j.properties
hive> show databases;
OK
data
default
demo
Time taken: 0.971 seconds, Fetched: 3 row(s)
hive>

 

I have granted the proper permission in ranger.

 

 

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions

New Contributor

Disregard, fixed the issue by update Ranger Settings:

 

Ranger -> Advanced -> Ranger Settings: 

Updated External URL from public dns (using AWS) to Private DNS.

 

Restarted services and now beeline is working properly. 

View solution in original post

Expert Contributor

You need to provide ALL access  to the User in the Ranger.

Please check the ranger permission settings in Ranger UI

View solution in original post

3 REPLIES 3

New Contributor

Disregard, fixed the issue by update Ranger Settings:

 

Ranger -> Advanced -> Ranger Settings: 

Updated External URL from public dns (using AWS) to Private DNS.

 

Restarted services and now beeline is working properly. 

View solution in original post

New Contributor

Hi, we are also running into same issue in CDP. Could you please let us know what exact configuration you changed to make it work..?

Thanks

Expert Contributor

You need to provide ALL access  to the User in the Ranger.

Please check the ranger permission settings in Ranger UI

View solution in original post