Support Questions
Find answers, ask questions, and share your expertise

How to SSH into HortonWorks Sandbox using Putty?

New Contributor

Hi!

I have successfully downloaded and installed Hortonworks Sandbox. And i can bring it up in the Oracle Virtual Box. Now, i want to SSH into it. I am using Putty, i am n Windows 7. But every time i try to login as 'root' with password 'hadoop'; it says access denied. Could anyone please provide any pointers as to what could be going wrong? Screenshots below.

Thanks, in advance.

904-sandbox.png

905-putty1.png

906-putty2.png

1 ACCEPTED SOLUTION

Super Guru

Goto terminal of your sandbox in oracle virtualBox --> Press <Alt+F5> --> enter username - root --> enter password - hadoop --> it will ask you to set new password --> set new password --> then try to login via putty using new credentials

View solution in original post

14 REPLIES 14

Super Guru

Goto terminal of your sandbox in oracle virtualBox --> Press <Alt+F5> --> enter username - root --> enter password - hadoop --> it will ask you to set new password --> set new password --> then try to login via putty using new credentials

New Contributor

@Kuldeep Kulkarni

Thanks for your response and do excuse me if this sounds silly; am just getting started. Issue is this, once the virtual box comes up, typing "Alt+F5" doesn't do anything. Where am i going wrong? I tried changing the input preference to "Auto capture keyboard" by clicking the box on and off, still not working.

900-sandbox1.png

Guru

Hi @jb brahma ,

you just have to click into the VirtualBox window (the black terminal screen) to put the focus on it. Afterwards you can get to the login screen by hitting Alt+F5

1139-virtualbox-login.png

Regards, Gerd

The Sandbox also comes with browser based ssh client (Shell in the box).

First bring up the Sandbox splash screen by entering the URL displayed in the console. By default it should be http://127.0.0.1:8888 for VirtualBox.

Then go to the first tab "get started" and click the "View Advance Options". This will list a collection of additional URLs and credentials for additional tools in the sandbox including shell in the box.

New Contributor

@Rafael Coss: 'root' with password 'hadoop' does not work in browser-based Sandbox. i can get into Hue but not in the shell. i am waiting reply from @jb brahma.

thanks.

New Contributor

@jb thanks for posting. I am having same problem. were you able to resolve the issue ?

New Contributor

I've got a similar problem. I can ssh with root/hadoop but I can't change the password. Doing it from an ssh client closes the connection with a 'Connection to 127.0.0.1 closed.' message as soon as enter a new password. And logging in via hte sandbox keeps resetting to the login screen.

Explorer

If the password changing prompt is not coming please do the following that works for me :

9571-hortonworks-blog1.png

Just use the ALT+F5 in splash screen -> enter root/hadoop as use name and password -> type passwd (to change the password of root user) -> write two times the new desired password you want.

And use the same password into any client like putty/MobaXterm or you name it. (all the connection details will be the same port is 2222 and host would be localhost/127.0.0.1 will work)

Hope this would help.

Explorer

This was very useful! I am able to change the password from hadoop to something else and exit from shell and relogin with new password. Thanks for this Indrajeet!

New Contributor

Hi,

If you ssh xxx.xxx.xxx.xxx -p 22 you'll be in Centos and you'll be able to use root. For this, use with ALT+F5 or putty.

If you ssh xxx.xxx.xxx.xxx -p 2222 you'll be connected to the sandbox (ie docker). In docker, you'll be able to use the predefined accounts (maria_dev, raj_ops, ... ) but not root... guess why ;-).

Explorer

I have tried this just now after what "indrajeet gour Nov 17, 2016 at 07:21 PM suggested."

What you do is: In your VM Player 12 and HDP 2.5, login using root / hadoop credentials. Then use passwd command and change the password to laurent1 (for example). Exit. Re-login using root / hadoop in VM Player. It will not allow you because you changed the password. Re-login using laurent1 password, it will work!

You can use the new credentials for Putty SSH port 22 and port 2222. Default maria_dev and raj_ops get eliminated because of passwd command. You can also use ssh xxx.xxx.xxx.xxx -p 22 or 2222 with new password laurent1. It will work.

New Contributor

Hi all... i was facing the same issue but my issue has been resolved by just only changing the port from 22 to 2222.

try 2222 ssh port if you are not able to connect on 22 ssh port.

Explorer

Hello all, i download virtualbox sandbox appliance & started successfully; however like to configure new ip address as assign 2 adapter -NAT, Host only- i observed sandbox host is not getting IP address; can someone advise me pls

Explorer

seems 2 adapter is not accepting?

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.