Support Questions
Find answers, ask questions, and share your expertise

How to resolve this ? [ERROR] Failed to execute goal on project storm-kafka: Could not resolve dependencies for project org.apache.storm:storm-kafka:jar:2.0.0-SNAPSHOT

Contributor

The following artifacts could not be resolved: org.apache.kafka:kafka_2.10:jar:0.8, org.apache.kafka:kafka-clients:jar:0.8: Could not find artifact org.apache.kafka:kafka_2.10:jar:0.8 in central (http://repo1.maven.org/maven2/) -> [Help 1] .

I'm trying to run storm-starter and I'm unable to solve this due to dependency issues.

13 REPLIES 13

Re: How to resolve this ? [ERROR] Failed to execute goal on project storm-kafka: Could not resolve dependencies for project org.apache.storm:storm-kafka:jar:2.0.0-SNAPSHOT

Mentor

@keerthana gajarajakumar pick the Kafka dependency out of this pom and copy HDP repositories section Link furthermore, this doc can really help you , it has a chapter on Kafka but its recommended to read it all, its short. Link

Re: How to resolve this ? [ERROR] Failed to execute goal on project storm-kafka: Could not resolve dependencies for project org.apache.storm:storm-kafka:jar:2.0.0-SNAPSHOT

Contributor

@Artem Ervits -- Thanks. Are you suggesting me to add the KafkaHBaseBenchmar, Maven Shade Plugin and Hadoop Dependency to the pom.xml within Storm-Kafka ??

Re: How to resolve this ? [ERROR] Failed to execute goal on project storm-kafka: Could not resolve dependencies for project org.apache.storm:storm-kafka:jar:2.0.0-SNAPSHOT

Mentor

@keerthana gajarajakumar

<plugins>
      <plugin>
         <groupId>org.apache.maven.plugins</groupId>
         <artifactId>maven-shade-plugin</artifactId>
         <version>1.4</version>
         <configuration>
             <createDependencyReducedPom>true</createDependencyReducedPom>
         </configuration>
         <executions>
          <execution>
            <phase>package</phase>
            <goals>
                <goal>shade</goal>
            </goals>
            <configuration>
                <transformers>
                    <transformer
                            implementation="org.apache.maven.plugins.shade.resource.ServicesResourceTransformer"/>
                    <transformer
                            implementation="org.apache.maven.plugins.shade.resource.ManifestResourceTransformer">
                        <mainClass></mainClass>
                    </transformer>
                </transformers>
                <filters>
                  <filter>
                    <artifact>*:*</artifact>
                    <excludes>
                      <exclude>META-INF/*.SF</exclude>
                      <exclude>META-INF/*.DSA</exclude>
                      <exclude>META-INF/*.RSA</exclude>
                    </excludes>
                  </filter>
                </filters>
            </configuration>
          </execution>
         </executions>
      </plugin>
    </plugins>
        <resources>
            <resource>
                <directory>src/main/resources</directory>
            </resource>
        </resources>
    </build>
    <repositories>
        <repository>
            <id>HDPReleases</id>
            <name>HDP Releases</name>
            <url>http://repo.hortonworks.com/content/repositories/public</url>
            <layout>default</layout>
            <releases>
                <enabled>true</enabled>
                <updatePolicy>always</updatePolicy>
                <checksumPolicy>warn</checksumPolicy>
            </releases>
            <snapshots>
                <enabled>false</enabled>
                <updatePolicy>never</updatePolicy>
                <checksumPolicy>fail</checksumPolicy>
            </snapshots>
        </repository>
        <repository>
            <id>HDPJetty</id>
            <name>Hadoop Jetty</name>
            <url>http://repo.hortonworks.com/content/repositories/jetty-hadoop/</url>
            <layout>default</layout>
            <releases>
                <enabled>true</enabled>
                <updatePolicy>always</updatePolicy>
                <checksumPolicy>warn</checksumPolicy>
            </releases>
            <snapshots>
                <enabled>false</enabled>
                <updatePolicy>never</updatePolicy>
                <checksumPolicy>fail</checksumPolicy>
            </snapshots>
        </repository>
        <repository>
            <snapshots>
                <enabled>false</enabled>
            </snapshots>
            <id>central</id>
            <name>bintray</name>
            <url>http://jcenter.bintray.com</url>
        </repository>
    </repositories>
    <dependencies>
        <dependency>
            <groupId>org.apache.storm</groupId>
            <artifactId>storm-kafka</artifactId>
            <version>${storm-kafka.version}</version>
        </dependency>
        <dependency>
            <groupId>org.apache.storm</groupId>
            <artifactId>storm-core</artifactId>
            <version>${storm-core.version}</version>
            <scope>provided</scope>
        </dependency>
        <dependency>
            <groupId>org.apache.kafka</groupId>
            <artifactId>kafka_2.10</artifactId>
            <version>${kafka.version}</version>
            <exclusions>
                <exclusion>
                    <groupId>javax.jms</groupId>
                    <artifactId>jms</artifactId>
                </exclusion>
                <exclusion>
                    <groupId>com.sun.jdmk</groupId>
                    <artifactId>jmxtools</artifactId>
                </exclusion>
                <exclusion>
                    <groupId>com.sun.jmx</groupId>
                    <artifactId>jmxri</artifactId>
                </exclusion>
                <exclusion>
                    <groupId>org.slf4j</groupId>
                    <artifactId>slf4j-log4j12</artifactId>
                </exclusion>
            </exclusions>
        </dependency>
        <dependency>
            <groupId>com.googlecode.json-simple</groupId>
            <artifactId>json-simple</artifactId>
            <version>1.1.1</version>
        </dependency>

Re: How to resolve this ? [ERROR] Failed to execute goal on project storm-kafka: Could not resolve dependencies for project org.apache.storm:storm-kafka:jar:2.0.0-SNAPSHOT

Mentor

these are my version variables

<kafka.version>0.8.2.2.3.0.0-2557</kafka.version>
<storm-kafka.version>0.10.0.2.3.0.0-2557</storm-kafka.version>
<storm-core.version>0.10.0.2.3.0.0-2557</storm-core.version>
<storm-hbase.version>0.10.0.2.3.0.0-2557</storm-hbase.version>
<hadoop-hdfs.version>2.7.1.2.3.0.0-2557</hadoop-hdfs.version>
<hadoop-common.version>2.7.1.2.3.0.0-2557</hadoop-common.version>

Re: How to resolve this ? [ERROR] Failed to execute goal on project storm-kafka: Could not resolve dependencies for project org.apache.storm:storm-kafka:jar:2.0.0-SNAPSHOT

Contributor

@Artem Ervits - Thanks. So, there are a couple of pom.xml files within Storm folder that I downloaded from git (using git clone command) . One within Storm-Master and the other within Storm-Kafka. Which one are you suggesting to be replaced with the code you have posted? Please clarify.

Re: How to resolve this ? [ERROR] Failed to execute goal on project storm-kafka: Could not resolve dependencies for project org.apache.storm:storm-kafka:jar:2.0.0-SNAPSHOT

Mentor

your issues is specifically with storm-kafka so I would just pick repositories block, storm-kafka, kafka_2.10, and storm-core. It's our recommendation to use our branch. I am sorry to confuse you. @keerthana gajarajakumar The user guide I provided earlier should have all documentation about this.

Re: How to resolve this ? [ERROR] Failed to execute goal on project storm-kafka: Could not resolve dependencies for project org.apache.storm:storm-kafka:jar:2.0.0-SNAPSHOT

Contributor

@Artem Ervits -- No Problem Artem, I'll change it based on your suggestion. I have absolutely no idea about Storm so, that's why I'm having some doubts but as always thanks for taking the time to help me. Good Day!

Re: How to resolve this ? [ERROR] Failed to execute goal on project storm-kafka: Could not resolve dependencies for project org.apache.storm:storm-kafka:jar:2.0.0-SNAPSHOT

Mentor

@keerthana gajarajakumar read the Hortonwors Storm User Guide, it will really help you, it's not a long read but will save you hours if not days.

Re: How to resolve this ? [ERROR] Failed to execute goal on project storm-kafka: Could not resolve dependencies for project org.apache.storm:storm-kafka:jar:2.0.0-SNAPSHOT

Contributor

Sure I'll check it out.