Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

How to run Atlas sample example in Hortonworks Ambari Cluster ?

Solved Go to solution

How to run Atlas sample example in Hortonworks Ambari Cluster ?

New Contributor

We are using Hortonworks Ambari cluster, recently configured Atlas.

1. Atlas UI is working fine, opening in 21000 port.

2. Successfully run ./import-hive.sh script after importing required jar in bridge/hive folder

Now how can I see my tables in Atlas. I have created table in hive. Data flow mysql --> sqoop --> hive

Do I need to create new flow after every configuration change or Atlas is working for old tables as well.

Gone through various link like: https://github.com/shivajid/atlas/tree/master/tutorial but still not clear about the steps

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: How to run Atlas sample example in Hortonworks Ambari Cluster ?

New Contributor

@Pardeep Gorla -

If import-hive.sh was executed correctly, then you should be able to query for hive tables through the Atlas UI using syntax such as:

hive_table

hive_table where tableName="employee"

This will make use of the Atlas DSL to search as opposed to the free text search which the Atlas UI will default to IF the DSL query does not yield any results.

2 REPLIES 2
Highlighted

Re: How to run Atlas sample example in Hortonworks Ambari Cluster ?

New Contributor

@Pardeep Gorla -

If import-hive.sh was executed correctly, then you should be able to query for hive tables through the Atlas UI using syntax such as:

hive_table

hive_table where tableName="employee"

This will make use of the Atlas DSL to search as opposed to the free text search which the Atlas UI will default to IF the DSL query does not yield any results.

Re: How to run Atlas sample example in Hortonworks Ambari Cluster ?

New Contributor

Thanks @ebergenholtz. Query is now returning a data. I was running wrong query.

Now query is returning value but no lineage data found message is showing in input and output but in details it is showing it is import from sqoop. Please help.firstresult.jpgdetails.jpginput.jpg

If possible, can you please help me to understand Atlas more what all the things I can do with Atlas and exactly what configuration, tables, flow I need to create so it give me desired output.

Any suggested tutorial.