Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

I have upgraded HDP to 2.6.4.0, but can't delete the old HDP version? Any suggestions?

avatar
Contributor

107511-1553757038175.png

1 ACCEPTED SOLUTION

avatar
Super Collaborator
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
6 REPLIES 6

avatar
Contributor

Prepare to upgrade to Spark-2.2.0, but when Ambari adds services, only Spark 2.1.1.

107432-1553757328497.png

avatar
Super Collaborator
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Contributor

When adding the service, I found that the local repo was not being used. Instead, a remote hdp repo is used.

107443-1553768895499.png

avatar
Contributor

Ambari Version is 2.6.1.0 and HDP Version is 2.6.4.0 .

avatar
Contributor

I know, this is the problem that is displayed. During the installation process, I still use my local repo. I guess it may be a bug after Ambari upgrade!

avatar
Super Collaborator

In /etc/yum.repos.d, remove all .repo files pointing to the Internet and copy only .repo files from other servers which are already using your local repo. For HDP nodes, initially you need only 2 .repo files, one for the OS, and ambari.repo. When Ambari adds a new node to the cluster it will copy there HDP.repo and HDP-UTILS.repo. Also, have you set your repository URLs in Ambari-> Admin-> Stack and versions-> Versions -> Manage Versions -> [click on your current version] ?