Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 10-31-2021 07:42 PM - edited 09-16-2022 07:44 AM
Hello,
We are observing error in Impala Catalouge Logs as below
EI1101 14:52:24.768759 8438 jni-util.cc:308] org.apache.impala.common.InternalException: Error updating the catalog due to lock contention.
at org.apache.impala.service.CatalogOpExecutor.updateCatalog(CatalogOpExecutor.java:3474)
at org.apache.impala.service.JniCatalog.updateCatalog(JniCatalog.java:308)
I1101 14:52:24.768983 8438 status.cc:125] InternalException: Error updating the catalog due to lock contention.
@ 0x9812da
@ 0xd37e2f
@ 0x970728
@ 0x960e7f
@ 0xa1f263
@ 0xa1752f
@ 0x948d4a
@ 0xb420c9
@ 0xb39fc9
@ 0xb3adc2
@ 0xdab24f
@ 0xdaba4a
@ 0x13346fa
@ 0x7fb75bf7cea5
@ 0x7fb75bca59fd
CM / CDH - 5.16.2
Appericate any assistacne / guidance in fixing this issue.
Thanks
Wert
Created 11-03-2021 02:55 AM
Hi @ChethanYM
load_catalog_in_background is unchecked, we were not observing any JVM pauses in Catalogue Logs, however, we were seeing RPC related alerts, we have restarted Impala and the issue seems to have been fixed.
Thanks
Wert
Created on 11-01-2021 04:35 AM - edited 11-01-2021 04:36 AM
Hi @wert_1311 ,
Seems to be "load_catalog_in_background" option is set to true in your cluster,
This can result in lock contention. The recommended value for this parameter is false. Please change the value to False and see if this helpful.
And if you are also seeing any JVM pauses in the catalog logs try to increase the catalog heap size and monitor the cluster.
https://docs.cloudera.com/documentation/enterprise/5-16-x/topics/impala_config_options.html
Regards,
Chethan YM
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Created 11-03-2021 02:55 AM
Hi @ChethanYM
load_catalog_in_background is unchecked, we were not observing any JVM pauses in Catalogue Logs, however, we were seeing RPC related alerts, we have restarted Impala and the issue seems to have been fixed.
Thanks
Wert