Support Questions
Find answers, ask questions, and share your expertise

Impala kerberos error

Explorer

Hi,

 

Since kerberos (AD) is activated, impala services are down (catalogserver and daemoin), except Impala StateStore.

 

-----------------------------------------------------------------------------------------------------------------

From impala catalog server log :

 

9:52:23.336 AM     INFO     status.cc:44     

Couldn't open transport for ESLT35020.edc.carrefour.com:24000(No more data to read.)
    @           0x74d01d  (unknown)
    @           0xa0139a  (unknown)
    @           0xa0145b  (unknown)
    @           0x8e121c  (unknown)
    @           0x8e1886  (unknown)
    @           0x937bed  (unknown)
    @           0x938613  (unknown)
    @           0x72409c  (unknown)
    @           0x71e833  (unknown)
    @       0x374dc1ed1d  (unknown)
    @           0x71e489  (unknown)

9:52:23.336 AM     INFO     thrift-client.cc:53     

Unable to connect to ESLT35020.edc.carrefour.com:24000

9:52:23.336 AM     INFO     thrift-client.cc:59     

(Attempt 1 of 10)

9:52:26.337 AM     INFO     status.cc:44     

No more data to read.
    @           0x74d01d  (unknown)
    @           0x937ce8  (unknown)
    @           0x938613  (unknown)
    @           0x72409c  (unknown)
    @           0x71e833  (unknown)
    @       0x374dc1ed1d  (unknown)
    @           0x71e489  (unknown)

9:52:26.337 AM     INFO     statestore-subscriber.cc:190     

statestore registration unsuccessful: No more data to read.

9:52:26.337 AM     ERROR     catalogd-main.cc:72     

No more data to read.

 

--------------------------------------------------------------------------------------

 

Could you please help me ?

 

regards,

 

1 ACCEPTED SOLUTION

Explorer

Thanks for the response. I have been meaning to come back and add a comment here. I found the root of the problem as well as the solution here:

 

http://community.cloudera.com/t5/Interactive-Short-cycle-SQL/kerberos-authentication-failure-GSSAPI-...

 

View solution in original post

5 REPLIES 5

Explorer

Hi,

 

I've upgraded into CDH 5.3 and the issue still persist !

 

regards,

Hi 

I am also facing same issue ..

 

did you get any solution for this ????

Explorer
I've also hit this issue. Did you resolve it?

Cloudera Employee

Hi,

 

Can you try enabling kerberos logging (-krb5_debug_file=name) and sharing the output with us?

 

Thanks

Explorer

Thanks for the response. I have been meaning to come back and add a comment here. I found the root of the problem as well as the solution here:

 

http://community.cloudera.com/t5/Interactive-Short-cycle-SQL/kerberos-authentication-failure-GSSAPI-...

 

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.