Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

In Atlas-Ranger sandbox machine,atlas not working properly?

Solved Go to solution

In Atlas-Ranger sandbox machine,atlas not working properly?

Expert Contributor

Hello guys,

My atlas-ranger machine is up and all services are running smothly over the node.

A question is, atlas just displaying lineage for hive,if we fire a query through beeline.I meant,it's providing lineage/metadata for hive tables only when we perform hive operation by connecting to hiveserver2 using beeline(i.e, only for jdbc connection).

Why it's not capturing hive metadata,when we use hive cli?

What I should do to resolve this problem?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: In Atlas-Ranger sandbox machine,atlas not working properly?

Hi @Manoj Dhake

Great question - You are correct, Hive CLI does not utilize HiveServer2, instead it goes directly to HCatalog for metadata info. Atlas has a hook that runs with HiveServer2, therefore Atlas will not receive any updates from Hive CLI. I would suggest disabling Hive CLI and running Beeline and/or Hive View (in Ambari) which both interact with HiveServer2.

View solution in original post

4 REPLIES 4
Highlighted

Re: In Atlas-Ranger sandbox machine,atlas not working properly?

Hi @Manoj Dhake

Great question - You are correct, Hive CLI does not utilize HiveServer2, instead it goes directly to HCatalog for metadata info. Atlas has a hook that runs with HiveServer2, therefore Atlas will not receive any updates from Hive CLI. I would suggest disabling Hive CLI and running Beeline and/or Hive View (in Ambari) which both interact with HiveServer2.

View solution in original post

Highlighted

Re: In Atlas-Ranger sandbox machine,atlas not working properly?

Expert Contributor

Thank you Ryan,

This will really help me.One more question,

1) Do we need to stick to beeline to get the lineage in atlas?

I meant,there is no way to come out of this?

2) The demo given on hortonworks website for atlas-ranger is works fine in sandbox,so is it like that atlas and ranger works only for that demo?

Because i tried to add some ranger policy in integration with atlas but those are not working properly.

I have used same user hr_user and hr_admin to define ranger and atlas policy.

Highlighted

Re: In Atlas-Ranger sandbox machine,atlas not working properly?

Hi @Manoj Dhake -> thanks for accepting my answer.

1) We recommend using Ambari "Hive Views" - when using Hive. Hive views will utilize HiveServer2, which will use the Hive Hook with Atlas - so you can view your data lineage in Atlas.

2) Atlas/Ranger will work beyond that demo (they should work properly for all cases). What policy are you trying to add? What does Ranger "Audit" tab show you as your denial error?

Highlighted

Re: In Atlas-Ranger sandbox machine,atlas not working properly?

Expert Contributor

Thank you ran,

I have used hive-view for seeing data lineage part in atlas but you know that,we have Atlas and Ranger integration which is mainly talks about "Tag based Policy".I have attached a link which explains demo of "Tag based policy".

Link------>

http://hortonworks.com/hadoop-tutorial/tag-based-policies-atlas-ranger/

In that demo they have used hive view to see/cross check whether security policy is really working or not?

Instead of using "Hive view",can we cross check same flow with the beeline?.I meant,

can we login to beeline with hr_user/hr_admin user to check the Atlas-Ranger tag based policy?.

Don't have an account?
Coming from Hortonworks? Activate your account here