Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-01-2023 06:04 AM
Hello
i have the following problems when i use hbase hbck
10 inconsistencies detected.
Status: INCONSISTENT
2023-02-01 13:51:01,346 INFO [main] zookeeper.ZooKeeper: Session: 0x1860d1d2ec00091 closed
2023-02-01 13:51:01,346 INFO [main] client.ConnectionManager$HConnectionImplementation: Closing master protocol: MasterService
2023-02-01 13:51:01,346 INFO [main] client.ConnectionManager$HConnectionImplementation: Closing zookeeper sessionid=0x1860d1d2ec00092
2023-02-01 13:51:01,346 INFO [main-EventThread] zookeeper.ClientCnxn: EventThread shut down
2023-02-01 13:51:01,349 INFO [main] zookeeper.ZooKeeper: Session: 0x1860d1d2ec00092 closed
2023-02-01 13:51:01,349 INFO [main-EventThread] zookeeper.ClientCnxn: EventThread shut down
Also am unable to create a new table and this is the message that is being displayed when i use
create 'users','userinfo'
ERROR: java.io.IOException: Table Namespace Manager not ready yet, try again later
Created 02-28-2023 08:43 PM
Hello @Menyawy
Thanks for using Cloudera Community. The Error [1] indicates your Team is using CDH v5.x using HBase v1.x. In the concerned release, We have limited choices to ensure "hbase:namespace" Table Region is assigned correctly as shared below:
(I) Easier Yet Not-Always-Successful Option:
1) Shutdown HBase Service
2) echo "rmr /hbase" | hbase zkcli (From HMaster Node)
3) Start HBase Service
4) sudo hbase hbase hbck -fixAssignments(II) Review whether any of the "hbase:namespace" Table Region files are reporting MissingBlockException. If Yes, We need to fix the MissingBlockException.
(III) Possible for the RegionServer Logs (Wherein the "hbase:namespace" Table Region is being assigned) would offer additional insight into the reasoning for the RegionServer being Unable to assign the "hbase:namespace" Table Region successfully. Your Team may review the concerned RegionServer Logs as well.
There may be Other Options, yet such Inconsistencies are better handled in HBase 2.x [1] & your Team should plan for using HBase v2.x soon.
Regards, Smarak
Created 02-28-2023 08:43 PM
Hello @Menyawy
Thanks for using Cloudera Community. The Error [1] indicates your Team is using CDH v5.x using HBase v1.x. In the concerned release, We have limited choices to ensure "hbase:namespace" Table Region is assigned correctly as shared below:
(I) Easier Yet Not-Always-Successful Option:
1) Shutdown HBase Service
2) echo "rmr /hbase" | hbase zkcli (From HMaster Node)
3) Start HBase Service
4) sudo hbase hbase hbck -fixAssignments(II) Review whether any of the "hbase:namespace" Table Region files are reporting MissingBlockException. If Yes, We need to fix the MissingBlockException.
(III) Possible for the RegionServer Logs (Wherein the "hbase:namespace" Table Region is being assigned) would offer additional insight into the reasoning for the RegionServer being Unable to assign the "hbase:namespace" Table Region successfully. Your Team may review the concerned RegionServer Logs as well.
There may be Other Options, yet such Inconsistencies are better handled in HBase 2.x [1] & your Team should plan for using HBase v2.x soon.
Regards, Smarak