Support Questions
Find answers, ask questions, and share your expertise

Installation Nifi Error when starting Nifi Node

New Contributor

Hi All,

I have a problem when add service nifi in my cluster, when nifinode starting it failed :

Code: 400 Output: {"statusCode":400,"msgDesc":"Operation denied. Group name: nifi specified in policy does not exist in ranger admin."}
Failed to create ranger policy...
Ensure Ranger has following groups:nifi
Ensure Ranger has following users:
Code: 400 Output: {"statusCode":400,"msgDesc":"Operation denied. Group name: nifi specified in policy does not exist in ranger admin."}
Failed to create ranger policy...
Ensure Ranger has following groups:nifi
Ensure Ranger has following users:

It says nifi group not exist in ranger instead user nifi has exist in ranger, but when i try to create manually nifi group in ranger, it solved.

Is it any ways to create automatically nifi group without create manually in ranger?

 

Thanks n Regards

 

Meidi

1 ACCEPTED SOLUTION

Super Collaborator

@RizkyMei You need to create nifi group manually , you can refer to the following doc for more info

 

https://docs.cloudera.com/cfm/2.0.1/deployment/topics/cfm-security-add-nifi-nifiregistry-user-comput...

View solution in original post

2 REPLIES 2

Super Collaborator

@RizkyMei You need to create nifi group manually , you can refer to the following doc for more info

 

https://docs.cloudera.com/cfm/2.0.1/deployment/topics/cfm-security-add-nifi-nifiregistry-user-comput...

New Contributor

Thanks for your suggestion @Scharan, i didn't read that docs before.

 

Thanks n Regards

 

Meidi

; ;