Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
08-02-2024
02:16 PM
- last edited on
04-20-2026
11:27 PM
by
GrazittiAPI
I'm trying to Insert into a table located in /warehouse/tablespace/managed/hive from a table located in /warehouse/tablespace/external/hive using beeline.
But I'm getting:
Select * from both tables works fine.
INSERT OVERWRITE TABLE <Managed_Table>
SELECT FROM .... <External_Table> ... Fails.
Any Idea?
Created 08-02-2024 09:34 PM
Hi, it seems like your external table is on top of the HBase table, you can check the application logs and see which container is failing and on which node and look into that node manager logs.
Created 09-11-2024 06:29 AM
Hi @Marks_08
In Hive is HBase dependency is enabled? If No, can you follow the below doc
https://docs.cloudera.com/cdp-private-cloud-base/7.1.6/accessing-hbase/topics/hbase-configure-hive-h...
If yes, we require the complete HS2 logs as well as the Yarn application logs to troubleshoot further.
Along with that share us the DDL for both Managed and external tables
DESCRIBE FORMATTED <TABLE_NAME>;
SHOW CREATE TABLE <TABLE_NAME>;
Replace TABLE_NAME with the managed and external tables.
Thank You.