Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Issue with AMI with Parcel Preloaded

Solved Go to solution

Re: Issue with AMI with Parcel Preloaded

Expert Contributor

This is strange -- truthfully, it looks like all your settings are copacetic, yet Director is failing to detect them here. A few more questions:

1. Could you try (the URL difference is v7 vs. v11).
2. So, the parcel that's being downloaded now is specifically for RHEL/CentOS 6. What base AMI are you currently using to build preloaded AMIs for CM/your cluster? Is it possible there's a mismatch, i.e. using RHEL/CentOS 7? If this is so, you may have to modify to look for the parcel ending in el7 instead of el6.

As for multiple parcels -- this is doable, but the scripts as written do not support this, unfortunately. At the moment, you can either do this manually, or you can modify the packer scripts to download these other parcels. The latter shouldn't be too bad, but would require some packer familiarity.

I'm going to file a ticket internally for this feature, however, as it seems like a useful one.


Re: Issue with AMI with Parcel Preloaded


Thanks for your help! It finally works now!


Turns out that "normalizeInstance" has to set to true. It's a bit confusing though as in the comment it says the following and I thought most of them are already done in the preloaded AMI.

# Normalization includes:
# downloading and installing packages
# minimizing swappiness
# increasing the maximun number of open files
# mounting ephemeral disks
# resizing the root partition.

I will modify the packer scripts to download additional parcels we need. It will be great if you add support semi-preloeaded AMI so small parcels can be downloaded during provisioning.