Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Issue with HDP clients in datanode

Solved Go to solution
Highlighted

Issue with HDP clients in datanode

Contributor

Hi Team,

During installation from ambari, the HDP clients successfully got installed in one of our datanodes. However it seems like there is some error in datanode which we are not able to troubleshoot the issue. The heartbeat response is receiving as can be seen in ambari-agent.log file.I am attaching the screenshot for your kind review. Can you please help us here??

7494-capture.jpg

Thanks,

Rahul

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Issue with HDP clients in datanode

Contributor
@Constantin Stanca

Hi Constantin,

The issue was that a hadoop folder got created previously under /usr/hdp folder since there should be only 2 folders named 2.4.2.0-258 and current under /usr/hdp. There should not be any additional folders apart from two folders. After removing the hadoop folder from /usr/hdp, the issue got resolved.

Thanks,

Rahul

View solution in original post

2 REPLIES 2
Highlighted

Re: Issue with HDP clients in datanode

@Rahul Buragohain

1. Are the Ambari agents running? Please check their status.

2. Please check ambari-agent, ambari-metrics-monitor and ambari-server logs for recent ERROR. These logs are usually found under /var/log/ where they run. Each node in the cluster has the agent and the monitor. The ambari-server log is on the ambari server host. Log files rotate. Check the latest without a data stamp.

You can try something like

cat ambari.log | grep ERROR

or

tail -1000 ambari.log | grep ERROR

Just look at the timestamp to eliminate false positives.

Re: Issue with HDP clients in datanode

Contributor
@Constantin Stanca

Hi Constantin,

The issue was that a hadoop folder got created previously under /usr/hdp folder since there should be only 2 folders named 2.4.2.0-258 and current under /usr/hdp. There should not be any additional folders apart from two folders. After removing the hadoop folder from /usr/hdp, the issue got resolved.

Thanks,

Rahul

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here