Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Issue with HUE

Solved Go to solution
Highlighted

Issue with HUE

Rising Star
Successfully installed HUE and modified all the parameter in HUE.INI such as webhdfs_url and set the parameter in HDFS configuration (proxyuser) and enabled webhdfs, But HUE is not able to connect to HDFS file system. It's trying at the URL: http://localhost:50070/webhdfs/v1 BUT correct hostname is listed in hue.ini. 

it doesnt seem to read the configuration from hue.ini. INI.
below is what I am getting from HUE web interface. 

Potential misconfiguration detected. Fix and restart Hue.


hadoop.hdfs_clusters.default.webhdfs_url	Current value: http://localhost:50070/webhdfs/v1/
Failed to access filesystem root
Resource Manager	Failed to contact Resource Manager at http://localhost:8088/ws/v1: HTTPConnectionPool(host='localhost', port=8088): Max retries exceeded with url: /ws/v1/cluster/apps (Caused by : [Errno 111] Connection refused)
Beeswax (Hive UI)	The application won't work without a running HiveServer2.
hcatalog.templeton_url	Current value: http://localhost:50111/templeton/v1/
HTTPConnectionPool(host='localhost', port=50111): Max retries exceeded with url: /templeton/v1/status?user.name=hue&doAs=hue (Caused by : [Errno 111] Connection refused)
Oozie Editor/Dashboard	The app won't work without a running Oozie server
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Issue with HUE

Rising Star

@Constantin Stanca & @Sindhu

Thanks guys problem solved. Actually hue_original.ini file was causing the problem. I made this copy to save the original comfiguration but HUE when it gets restarted, it reads all the INI files for configuration. I changed that file to .TXT and now HUE passes all the configuration.

thanks

View solution in original post

9 REPLIES 9
Highlighted

Re: Issue with HUE

@Prakash Punj

You say "modified all the parameter in HUE.INI". Does it mean you manually made those changes? If so, have you restarted Hue to account for the new changes? Look also at the ownership of the file. It may not be owned by Hue if you made the changes under a different account. If after restart, you still have the issue, are you pointing to the server that runs the Hive2 Server?

If helpful, vote/accept response.

Highlighted

Re: Issue with HUE

Rising Star

Thank you @Constantin Stanca @Neeraj Sabharwal

I manually made the change in HUE.INI to point to correct hiveserver2 and namenode/resource manager, also restarted HUE multiple times.

Please take a look at the ownership of HUE.INI file (root/root). I am using root account

Take a look at the HUE.INI which has entry for webhdfs_URL. it;s pointing to correct namenode

Also check the screenshot of the error I am getting.

Thanks

Prakash

[root@EdgeNode conf]# ls -l
total 48
-rwxr-xr-x. 1 root root  1785 Apr 20 16:12 hue_httpd.conf
-rwxr-xr-x. 1 root root 16999 Jul 22 14:03 hue.ini
-rwxr-xr-x. 1 root root 16845 Jul 22 12:51 hue_original.ini
-rwxr-xr-x. 1 root root  1984 Apr 20 16:12 log.conf

 # Enter the filesystem uri
      fs_defaultfs=hdfs://namenode.asotc.com:8020
      # Use WebHdfs/HttpFs as the communication mechanism. To fallback to
      # using the Thrift plugin (used in Hue 1.x), this must be uncommented
      # and explicitly set to the empty value.

      webhdfs_url=http://namenode.asotc.com:50070/webhdfs/v1/

6039-hue-issue.jpg


      ## security_enabled=true
Highlighted

Re: Issue with HUE

@Prakash Punj

Can you please check the contents of hue_original.ini and see if it is pointing to localhost?

If yes, move/remove the file from /etc/hue/conf folder, restart hue and then try.

Highlighted

Re: Issue with HUE

Rising Star

@Sindhu

hue_original.ini is the original copy of hue.ini which I made before modifying hue.ini with hadoop cluster information.

Highlighted

Re: Issue with HUE

@Prakash Punj

Could you publish your hue.ini files as text? The screenshots provided are a bit difficult to read and I would like to see the actual content.

Side question: which version of OS and HDP you use? Hue on Centos 7 and HDP 2,4 is not supported.

Highlighted

Re: Issue with HUE

Rising Star

@Constantin Stanca

I uploaded the Hadoop cluster configuration section from HUE.INI. please take a look.

Highlighted

Re: Issue with HUE

Rising Star

@Constantin Stanca

I am running HDP 2.4 on centos 6

Thanks

Re: Issue with HUE

Rising Star

@Constantin Stanca & @Sindhu

Thanks guys problem solved. Actually hue_original.ini file was causing the problem. I made this copy to save the original comfiguration but HUE when it gets restarted, it reads all the INI files for configuration. I changed that file to .TXT and now HUE passes all the configuration.

thanks

View solution in original post

Highlighted

Re: Issue with HUE

@Prakash Punj

Good lesson learned for all of us. It is a good practice to save a file with a name like hue.ini.old for anything unix. Hue is not the only that reads all .ini files from a directory.

Don't have an account?
Coming from Hortonworks? Activate your account here