Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

JAVA_HOME not set for clients

avatar
Explorer

CDM version: 5.7.1

I've set the Java Home Directory in the hosts config to /opt/java/jdk

It's picked up properly by all services, but not by clients

 

For example running the yarn command, it will complain JAVA_HOME is not set

 

The file used to check for JAVA_HOME is:

/opt/cloudera/parcels/CDH-5.7.1-1.cdh5.7.1.p0.11/lib/bigtop-utils/bigtop-detect-javahome

 

Apparently this file is not checking the hosts config setting. I'm surprised by that.

The info for this option says:

Explicitly set the value of JAVA_HOME for all processes. This will override the auto-detection logic that is normally used.

 

Why doesn't it apply to client processes?

 

thanks

1 ACCEPTED SOLUTION

avatar
Explorer
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
2 REPLIES 2

avatar
Contributor

avatar
Explorer
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login