Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Jetty web Server shutting down

avatar
Explorer

We have deployed NIFI application in AKS with 3 pods. The primary pod is working fine without error but pod1 and pod 2 are continuously restarting. I checked the logs for both, getting errors such as 

2024-04-05 11:04:52,015 INFO [Thread-1] Initiating shutdown of Jetty web server...

2024-04-05 11:04:52,020 INFO [Thread-1] Stopped ServerConnector@fb713e7{SSL,[ http/1.1]}{nifi-1.nifi-headless.iic-nifi-uat.svc.cluster.local:9443}

2024-04-05 11:04:52,021 INFO [Thread-1] node0 Stopped scavenging

I have checked the resources such as memory leaks and CPU consumption, everything seems to be in ideal state.  Kindly request insights from forum how to overcome this err

1 REPLY 1

avatar
Master Collaborator

Do you see any exceptions in the logs before you see the Initiating shutdown of Jetty web server?