Community Articles
Find and share helpful community-sourced technical articles
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.
Labels (1)
Super Guru

SYMPTOM

Oozie web UI doesn't work on Internet explorer in Kerberized environment, it gives below error message even after making sure that Ext JS libraries are installed correctly.

Oozie web console is disabled.To enable Oozie web console install the Ext JS library. 

ROOT CAUSE

https://issues.apache.org/jira/browse/OOZIE-2322 - Because of empty space as a value of oozie.authentication.cookie.domain

WORKAROUND

1. Set value of oozie.authentication.cookie.domain to name of your corporate domain in oozie-site.xml via Ambari UI.

Example:

<property>
<name>oozie.authentication.cookie.domain</name>
<value>hortonworks.com</value>
</property>

2. Stop Oozie server via Ambari.

3. Move oozie.war to some other location.

mv /usr/hdp/current/oozie-server/oozie-server/webapps/oozie.war /root/

4. Move Oozie webapp directory to some other location.

mv /usr/hdp/current/oozie-server/oozie-server/webapps/oozie /root/

5. Regenrate Oozie war file using below command

/usr/hdp/current/oozie-server/bin/oozie-setup.sh prepare-war

6. Start Oozie server via Ambari.

7. Clear the cookies from your browser and access Oozie WebUI.

RESOLUTION

This issue has been fixed in Oozie 4.3.0

10,695 Views
Comments

Actually, clearing cookies and rebooting my browser was enough for me since all previous steps were properly set.

Where can I find the oozie-site.xml in ambari UI ?

Cloudera Employee

Hi there,

I added oozie.authentication.cookie.domain=<domain> to Customer oozie-site and tried this. Doesn't work for me.

I finally solved it by installing extjs directly.

  1. wget http://archive.cloudera.com/gplextras/misc/ext-2.2.zip
  2. Stop Oozie service from Ambari
  3. Copy it to the path: /usr/hdp/current/oozie-client/libext
  4. Regenerate the war file by executing: $ /usr/hdp/current/oozie-server/bin/oozie-setup.sh prepare-war
  5. Start Oozie again

Hope this helps.

Don't have an account?
Coming from Hortonworks? Activate your account here
Version history
Revision #:
1 of 1
Last update:
‎10-13-2016 08:10 AM
Updated by:
 
Contributors
Top Kudoed Authors