Support Questions
Find answers, ask questions, and share your expertise

KUDU trusted subnets does not work

Solved Go to solution

KUDU trusted subnets does not work

After upgrade Cloudera Manager from 5.14.0 to 5.15.0 my trusted_subnets in KUDU configuration does not work. Also --trusted_subnets=0.0.0.0/0 does not work. I get an error in the impala-shell :

 

ERROR: TransmitData() to x.x.x.x:27000 failed: Not authorized: Client connection negotiation failed: client connection to x.x.x.x:27000: FATAL_UNAUTHORIZED: Not authorized: unencrypted connections from publicly routable IPs are prohibited. See --trusted_subnets flag for more information.: x.x.x.x:52167

 

My config is:

 

--trusted_subnets=0.0.0.0/0
--rpc-authentication=disabled
--rpc-encryption=disabled

1 ACCEPTED SOLUTION

Accepted Solutions

Re: KUDU trusted subnets does not work

Cloudera Employee

Hi @buddelflinktier,

 

Impala has started using KRPC for the TransmitData() RPC as well from 5.15. So you would need to configure the 'trusted_subnets' flag the same way in your Impala configuration as well (it doesn't pick it up from the Kudu configuration).

 

- Sailesh

View solution in original post

2 REPLIES 2

Re: KUDU trusted subnets does not work

Cloudera Employee

Hi @buddelflinktier,

 

Impala has started using KRPC for the TransmitData() RPC as well from 5.15. So you would need to configure the 'trusted_subnets' flag the same way in your Impala configuration as well (it doesn't pick it up from the Kudu configuration).

 

- Sailesh

View solution in original post

Re: KUDU trusted subnets does not work

Thanks, it works fine!