Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
08-25-2022
05:00 AM
- last edited on
04-21-2026
12:51 AM
by
GrazittiAPI
Hi ,
Kindly for your support, I'm trying to create a kudu table from impala shell after enabling kerberos but i got the following error:
ERROR: AnalysisException: Cannot analyze Kudu table 'courses_kudu': Error determining if Kudu's integration with the Hive Metastore is enabled: Couldn't find a valid master in (cloudera.ngdw.com:7051). Exceptions received: [org.apache.kudu.client.NonRecoverableException: Server requires Kerberos, but this client is not authenticated (missing or expired TGT)]
Kindly find attached steps and error returned.
Created 08-29-2023 08:51 AM
Hi @hebamahmoud
You mean even after configuring the KUDU-HMS integration you are still facing the same issue/error? Can you confirm?
Have you followed the given workaround on all HMS servers?
If that does not work can you try below and check?
CM > kudu > configuration> kudu service Advanced Configuration Snippet (Safety Valve) ==> --trusted_user_acl=impala,hive and restart the kudu services,
Regards,
Chethan YM
Created 08-02-2023 11:16 PM
Dear @hebamahmoud , seems we ran into this issue too. Have you fixed this issue? Thanks in advance.
Created 08-03-2023 01:53 AM
@dsajdklajdklsa, Welcome to our community! To help you get the best possible answer, I have tagged our experts @ChethanYM @willx @araujo @Shelton who may be able to assist you further.
Please feel free to provide any additional information or details about your query, and we hope that you will find a satisfactory solution to your question.
Regards,
Vidya Sargur,Created 08-29-2023 12:36 AM
Having the same issue while loading data from NIFI 1.21 to Kudu. Anyone find the solution?. I can connect to Kudu Via Hue and Impala
Created 08-29-2023 08:51 AM
Hi @hebamahmoud
You mean even after configuring the KUDU-HMS integration you are still facing the same issue/error? Can you confirm?
Have you followed the given workaround on all HMS servers?
If that does not work can you try below and check?
CM > kudu > configuration> kudu service Advanced Configuration Snippet (Safety Valve) ==> --trusted_user_acl=impala,hive and restart the kudu services,
Regards,
Chethan YM
Created 09-13-2023 07:00 AM
Hello @hebamahmoud
If the issue is has been from any of the above responses, Could you accept it as a solution?
Regards,
Chethan YM