Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

[Kerberos ][Cloudera manager 7] Unable to create a kudu table from impala shell after enabling kerberos

avatar
Explorer

Hi , 

Kindly for your support, I'm trying to create a kudu table from impala shell after enabling kerberos but i got the following error: 

 

ERROR: AnalysisException: Cannot analyze Kudu table 'courses_kudu': Error determining if Kudu's integration with the Hive Metastore is enabled: Couldn't find a valid master in (cloudera.ngdw.com:7051). Exceptions received: [org.apache.kudu.client.NonRecoverableException: Server requires Kerberos, but this client is not authenticated (missing or expired TGT)]

 

Kindly find attached steps and error returned. kerberos-kudu-impala-shell.png

 

1 ACCEPTED SOLUTION

avatar
Master Collaborator

Hi @hebamahmoud 

You mean even after configuring the KUDU-HMS integration you are still facing the same issue/error? Can you confirm?

Have you followed the given workaround on all HMS servers?

https://docs.cloudera.com/cdp-private-cloud-base/7.1.7/runtime-release-notes/topics/rt-pvc-known-iss...

 

If that does not work can you try below and check?

 

CM > kudu > configuration> kudu service Advanced Configuration Snippet (Safety Valve) ==> --trusted_user_acl=impala,hive and restart the kudu services,

 

Regards,

Chethan YM

 

View solution in original post

14 REPLIES 14

avatar

Dear @hebamahmoud , seems we ran into this issue too. Have you fixed this issue? Thanks in advance.

avatar
Community Manager

@dsajdklajdklsa, Welcome to our community! To help you get the best possible answer, I have tagged our experts @ChethanYM @willx @araujo @Shelton  who may be able to assist you further.

Please feel free to provide any additional information or details about your query, and we hope that you will find a satisfactory solution to your question.

 



Regards,

Vidya Sargur,
Community Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:

avatar
Rising Star

Having the same issue while loading data from NIFI 1.21 to Kudu. Anyone find the solution?. I can connect to Kudu Via Hue and Impala

avatar
Master Collaborator

Hi @hebamahmoud 

You mean even after configuring the KUDU-HMS integration you are still facing the same issue/error? Can you confirm?

Have you followed the given workaround on all HMS servers?

https://docs.cloudera.com/cdp-private-cloud-base/7.1.7/runtime-release-notes/topics/rt-pvc-known-iss...

 

If that does not work can you try below and check?

 

CM > kudu > configuration> kudu service Advanced Configuration Snippet (Safety Valve) ==> --trusted_user_acl=impala,hive and restart the kudu services,

 

Regards,

Chethan YM

 

avatar
Master Collaborator

Hello @hebamahmoud 

If the issue is has been from any of the above responses, Could you accept it as a solution?

Regards,

Chethan YM