Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Knox admin UI session length not respected with default provider?

Solved Go to solution

Knox admin UI session length not respected with default provider?

New Contributor

Hello,

I have used Ambari 2.7.3 to setup an HDP 3.1.0 + HDF 3.3.0 cluster, and am trying to configure Knox proxy functionality but am having problems...the Knox admin UI doesn't seem to respect the setting of 30 minute sessions with the ShiroProvider. I have verified that the configs in Ambari all specify sessionTimeout of 30, which is supposed to be 30 minutes, but I get logged-out almost immediately when trying to use the admin UI. If I click down into the default read-only topologies, and then try to navigate back into the providers, I have to re-login, even though it's on;y been like 30 seconds.

Any idea what the problem might be?

Thanks in advance,

Doug

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Knox admin UI session length not respected with default provider?

New Contributor

OK, I figured this out...the problem was with the default setting of knoxsso.token.ttl property, which was 30000 (30 seconds). I stopped the Knox service, updated the configuration in Ambari, restarted Knox, and now behavior is correct.

1 REPLY 1

Re: Knox admin UI session length not respected with default provider?

New Contributor

OK, I figured this out...the problem was with the default setting of knoxsso.token.ttl property, which was 30000 (30 seconds). I stopped the Knox service, updated the configuration in Ambari, restarted Knox, and now behavior is correct.