Support Questions

Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Launch Dashboard from Localhost:8888 Not Working

Explorer

I just followed the instructions at link to start using the docker image of the sandbox. When I go to localhost:8888 I click on the 'Launch Dashboard' button but this is what I get:

14079-dash.jpg

So I get a tutorial page but the whole 'localhost didn't send any data' thing seems wrong.

Not sure if it is related but when I ran the startup_script I get this WARNING for Starting Ranger-admin:

14099-startup2.jpg

Does this look okay?

And then lastly just to make sure this is ok, when I ran the " docker load < HDP_2.5_docker.tar" command, my output is different and smaller in size than what is shown in the link above. Here is what I get:

14097-screen-shot-2017-03-27-at-112427-am.png

And here is what the link has as output:

14098-screen-shot-2017-03-27-at-112532-am.png

Sorry for all the pics and info but just wanted to make sure I didn't miss anything to help figure out why things seem to not be working.

Thanks!


startup.jpg
17 REPLIES 17

Do you have a pop-up blocker on? If so, turn it off or provide access to the HDP Sandbox.

Explorer

I am also facing the same problem. can not launch dashboard from Localhost and not even able to login through putty

This is what the msg from putty

Network error : Software caused connection abort

Everything was working fine until yesterday


untitled.png

Super Mentor

@Jonathan T

Can you please check if you have port-forwarding enabled and the port 8080 is added to the list.

https://community.hortonworks.com/articles/65914/how-to-add-ports-to-the-hdp-25-virtualbox-sandbox.h...

Explorer

@Jay SenSharma

fine upto here

14085-sand.png

After this when go to bowser, it doesn't launch dashboard

Super Mentor

@pankaj kushwaha

Can you please share the output of the following screen so that we can see if port 8888 and 8080 are there in the list.

Right click on the "Sandbox" --> "Settings" --> "Network" --> "NAT" (Select) --> Click on "Advance" --> "Port Forwarding"

Explorer

@Jay SenSharma

Here is the output

14087-port1.png

14088-port2.png

Explorer

@Jay SenSharma

This is what, when I run start_sandbox.sh

14086-dock.png

Rising Star

@pankaj kushwaha hello, did your instance get terminated while running? To me your error looks like an FS issue and we've had a couple more instances where the overlayFS that docker uses got corrupted by incorrect shutdowns. If that's the case your best bet is re-importing the sandbox.

Explorer

@glupu

Thanks for your help, it worked after re-importing the sandbox.

What is the proper way to shutdown, I normally do the power off

Rising Star

@pankaj kushwaha Making sure all the services are stopped and then doing a shutdown command from inside the host VM is your best bet at making sure nothing gets broken.

Rising Star

@Jonathan T from what I understand you are trying to run the docker image of sandbox natively correct? In that case, what OS are you running on your machine. I'm asking because if it's ubuntu the problem you're probably running into is the fact that apparmor is blocking critical services of the sandbox container.

Explorer

@Rafael Coss, yes I turned off the pop-up blocker. I thought that was it too.

@Jay SenSharma, I pretty much just copy and pasted the docker run command and I believe it exposed port 8080

@glupu, yes I am running the docker sandbox from my mac which is using docker for mac.

I pretty much just followed the instructions from the link I posted above. I ran the 'docker run ...' command and then did a ssh -p 2222 root@localhost. I changed my password from 'hadoop' to my own and then ran /etc/init.d/startup_script start but after going to localhost:8888 the dashboard wouldn't launch.

So yesterday I ran 'service ambari-server status' and it said it wasn't running but gave a message about a 'Stale PID File at: /var/run/ambari-server/ambari-server.pid'. So I ran 'service ambari-server start' and again 'service ambari-server status' showed the same thing even tough the 'ambar-server start' command said it completed successfully. Finally I ran 'service ambari-server restart' and then it was running and I can get to the dashboard.

Why was that? And am I supposed to run the docker image of the sandbox this way? I noticed @jay had something which said 'Hortonworks Docker Sandbox' listed in his VirtualBox. I thought having a docker image was so that you didn't need a VM. So now I'm a bit confused on how I should be using the docker image of the sandbox. . .

thanks, I appreciate the help!

Rising Star

@Jonathan T The virtualbox and vmware versions of the sandbox are simply instances of virtualbox and vmware machines with the image pre-loaded onto them so if someone isn't accustomed to running scripts and/or installing docker on their machines they don't need to. Also docker so far isn't very OS friendly in that different distros present different bugs depending on flavors and kernel versions so downloading the vbox/vmware versions ensure that you're running it in an environment that was pre-screened to work accordingly.

Regarding the behavior you are experiencing I can't really form on opinion by just the output you submitted but if I were to guess it would probably be a docker-related issue and perhaps your docker/ambari logs will provide more insight. Is everything else running alright now that you managed to bring it up?

Explorer

@glupu,

I think it is ok. I haven't done much with it since seeing the Amabri log in screen so I don't really know. I actually am not sure what to do. I was hoping there was a tutorial that showed me what to do next so I can start working with HDP and getting to learn it and Hadoop

Rising Star

@Jonathan T If you have the VM up and running properly now, there are several tutorials at https://hortonworks.com/tutorials/. They cover all kinds of scenarios from data ingest to processing and visualization, so they are very helpful for learning Hadoop basics.

Explorer
@Mike Riggs

Thanks Mike for the tip. I guess all the references to VM I'll just kind of ignore and translate to me running on docker locally. Thanks all. I'll take a look see tomorrow or so and hopefully all is well.

Super Mentor

@Jonathan T

Instead of shutting down the VM completely i usually do "Save State" because there are many components running inside the VM and it takes some time to get all those services restarted.

But it depends on the usecase. If we have some time then sometimes it is better to restart the VM that way it is comparatively bit faster.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.