Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

MgMt has 0 Reprot managers

MgMt has 0 Reprot managers

New Contributor

Hello!

In the Cloudera Manager I get the following Configuration Errors:

 

 

 

If I add a Reports Manager as an Instance I have to configure the Database. The name, the pasword and the username is not set. The database is pre-defined as mysql and the database is cloudera. Do I have to get rid of this error and if so how.

 

I am a bit confused since it looks like no database is set but impala queries are working but hive does not, I will open another question about this.

 

br!

 

1 REPLY 1
Highlighted

Re: MgMt has 0 Reprot managers

New Contributor

I found this solution in another post:

 

****************************************************************

I tried doing the steps with following details

database host name : quickstart.cloudera

database type Mysql

 

But was not sure of the database name, user name, password.

 

Then went into terminal, loged into Mysql using

$mysql -uroot -pcloudera

 

And then listed all databases using mysql> show databases;

 

use one of them mysql> use database_name;

 

And then listed all tables using mysql> show tables;

 

created a table name as reportdb.

 

used table name as Reportdb, user as root and password as cloudera to create the report manager role succesfully.

 

This is just the next steps in the same chain. I thought it is better to keep it updated that might help people to see that.

****************************************************************

 

Now I do not get the error anymore. Another problem I have had was solved as well.