Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Mysql 5.6 install errro (Error: Package: mysql-community-server-5.6.35-2.el6.x86_64 (mysql56-community) Requires: perl(DBI))

Solved Go to solution

Mysql 5.6 install errro (Error: Package: mysql-community-server-5.6.35-2.el6.x86_64 (mysql56-community) Requires: perl(DBI))

Expert Contributor

OS:- Centos 6.8 64bit

Mysql : 5.6 version

Error as below

[root@~]# sudo yum install mysql-community-server
Loaded plugins: fastestmirror
Setting up Install Process
Repository HDP-UTILS-1.1.0.19 is listed
more than once in the configuration
Loading mirror speeds from cached hostfile Resolving Dependencies
--> Running transaction check
---> Package mysql-community-server.x86_64
0:5.6.35-2.el6 will be installed
--> Processing Dependency:
libmysqlclient.so.16()(64bit) for package: 2:postfix-2.6.6-6.el6_7.1.x86_64
--> Processing Dependency:
libmysqlclient.so.16(libmysqlclient_16)(64bit) for package:
2:postfix-2.6.6-6.el6_7.1.x86_64
--> Running transaction check
---> Package
mysql-community-libs-compat.x86_64 0:5.6.35-2.el6 will be obsoleting
---> Package
mysql-community-server.x86_64 0:5.6.35-2.el6 will be installed
--> Processing Dependency: perl(DBI) for
package: mysql-community-server-5.6.35-2.el6.x86_64
-->
Finished Dependency Resolution
Error:
Package: mysql-community-server-5.6.35-2.el6.x86_64 (mysql56-community)
           Requires: perl(DBI)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@c~]# 
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Mysql 5.6 install errro (Error: Package: mysql-community-server-5.6.35-2.el6.x86_64 (mysql56-community) Requires: perl(DBI))

Expert Contributor

I did the following this, mine issue has been Resolved

1)   Download the “Requires: perl(DBI)” package ,we are using centos 6.8 version, download the
 below RPM  perl-DBI-1.609-4.el6.x86_64.rpm

http://rpmfind.net/linux/rpm2html/search.php?query=perl-DBI

2) Install the perl DBI rpm on Linux server 

[root@centos2 ~]# rpm -ivh perl-DBI-1.609-4.el6.x86_64.rpm
Preparing...                ########################################### [100%]
   1:perl-DBI               ########################################### [100%]
[root@centos2 ~]#
3) [root@hostname ~]# sudo yum install mysql-community-server
Loaded plugins: fastestmirror
Setting up Install Process
Repository HDP-UTILS-1.1.0.19 is listed more than once in the configuration
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package mysql-community-server.x86_64 0:5.6.35-2.el6 will be installed
--> Processing Dependency: mysql-community-client(x86-64) >= 5.6.10 for package: mysql-community-server-5.6.35-2.el6.x86_64
--> Running transaction check
---> Package mysql-community-client.x86_64 0:5.6.35-2.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================================
 Package                                 Arch                    Version                        Repository                          Size
=========================================================================================================================================
Installing:
 mysql-community-server                  x86_64                  5.6.35-2.el6                   mysql56-community                   54 M
Installing for dependencies:
 mysql-community-client                  x86_64                  5.6.35-2.el6                   mysql56-community                   18 M

Transaction Summary
=========================================================================================================================================
Install       2 Package(s)

Total download size: 73 M
Installed size: 324 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): mysql-community-client-5.6.35-2.el6.x86_64.rpm                                                             |  18 MB     00:01
(2/2): mysql-community-server-5.6.35-2.el6.x86_64.rpm                                                             |  54 MB     00:04
-----------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                     11 MB/s |  73 MB     00:06
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
  Installing : mysql-community-client-5.6.35-2.el6.x86_64                                                                            1/2
  Installing : mysql-community-server-5.6.35-2.el6.x86_64                                                                            2/2
  Verifying  : mysql-community-client-5.6.35-2.el6.x86_64                                                                            1/2
  Verifying  : mysql-community-server-5.6.35-2.el6.x86_64                                                                            2/2

Installed:
  mysql-community-server.x86_64 0:5.6.35-2.el6

Dependency Installed:
  mysql-community-client.x86_64 0:5.6.35-2.el6

Complete!
[root@hostname ~]#
4) Verify the packages installed or not 
[root@hostname ~]# rpm -qa |grep mysql
mysql-community-common-5.6.35-2.el6.x86_64
mysql57-community-release-el6-9.noarch
mysql-community-libs-compat-5.6.35-2.el6.x86_64
mysql-community-libs-5.6.35-2.el6.x86_64
mysql-community-client-5.6.35-2.el6.x86_64
mysql-community-server-5.6.35-2.el6.x86_64
[root@hostname ~]#

[root@hostname ~]# service mysqld status
mysqld is stopped
[root@hostname ~]#

View solution in original post

4 REPLIES 4
Highlighted

Re: Mysql 5.6 install errro (Error: Package: mysql-community-server-5.6.35-2.el6.x86_64 (mysql56-community) Requires: perl(DBI))

Expert Contributor
[root@hostname ~]# sudo yum install mysql-community-server
Loaded plugins: fastestmirror
Setting up Install Process
Repository HDP-UTILS-1.1.0.19 is listed more than once in the configuration
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package mysql-community-server.x86_64 0:5.6.35-2.el6 will be installed
--> Processing Dependency: mysql-community-common(x86-64) = 5.6.35-2.el6 for package: mysql-community-server-5.6.35-2.el6.x86_64
--> Processing Dependency: mysql-community-client(x86-64) >= 5.6.10 for package: mysql-community-server-5.6.35-2.el6.x86_64
--> Processing Dependency: perl(DBI) for package: mysql-community-server-5.6.35-2.el6.x86_64
--> Running transaction check
---> Package mysql-community-client.x86_64 0:5.6.35-2.el6 will be installed
---> Package mysql-community-common.x86_64 0:5.6.34-2.el6 will be updated
---> Package mysql-community-common.x86_64 0:5.6.35-2.el6 will be an update
---> Package mysql-community-server.x86_64 0:5.6.35-2.el6 will be installed
--> Processing Dependency: perl(DBI) for package: mysql-community-server-5.6.35-2.el6.x86_64
--> Finished Dependency Resolution
Error: Package: mysql-community-server-5.6.35-2.el6.x86_64 (mysql56-community)
           Requires: perl(DBI)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

[root@hostname ~]# rpm -qa |grep mysql
mysql57-community-release-el6-9.noarch
mysql-community-common-5.6.34-2.el6.x86_64
mysql-community-libs-compat-5.6.35-2.el6.x86_64
mysql-community-libs-5.6.34-2.el6.x86_64
[root@hostname ~]#

[root@hostname ~]# service status mysqld
status: unrecognized service

Highlighted

Re: Mysql 5.6 install errro (Error: Package: mysql-community-server-5.6.35-2.el6.x86_64 (mysql56-community) Requires: perl(DBI))

Expert Contributor

While installation with skip and without skip Mysql database 5.6 .

Without Skip:- #sudo yum install mysql-community-server

******************************************************************************************************************

Error as below :-

--> Finished Dependency Resolution

Error: Package: mysql-community-server-5.6.35-2.el6.x86_64 (mysql56-community)

Requires: perl(DBI)

******************************************************************************************************************

2) With Skip :- # sudo yum install mysql-community-server --skip-broken

--> Finished Dependency Resolution

Packages skipped because of dependency problems:

mysql-community-client-5.6.35-2.el6.x86_64 from

mysql56-community mysql-community-common-5.6.35-2.el6.x86_64 from

mysql56-community mysql-community-libs-5.6.35-2.el6.x86_64 from

mysql56-community mysql-community-server-5.6.35-2.el6.x86_64 from mysql56-community

Dependencies Resolved

******************************************************************************************************************

Please advise

Highlighted

Re: Mysql 5.6 install errro (Error: Package: mysql-community-server-5.6.35-2.el6.x86_64 (mysql56-community) Requires: perl(DBI))

Super Mentor

@zkfs

First you should install the following dependency packages:

yum install -y numactl perl-DBI postfix

- MySQL community RPM repo: http://repo.mysql.com/yum/mysql-5.6-community/el/6/x86_64/

You can try the following steps:
yum install -y numactl perl-DBI postfix

/bin/cp -f RPM-GPG-KEY-mysql  /etc/pki/rpm-gpg/
rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-mysql

rpm -e --nodeps mysql-libs-5.1.73-5.el6_6.x86_64

# from this url to download the package 
# Version: 5.6 http://repo.mysql.com/yum/mysql-5.6-community/el/6/x86_64/
rpm -Uvh --force mysql-community-common-5.6.35-2.el6.x86_64.rpm
rpm -Uvh --force mysql-community-libs-5.6.35-2.el6.x86_64.rpm
rpm -Uvh --force mysql-community-libs-compat-5.6.35-2.el6.x86_64.rpm
rpm -Uvh --force mysql-community-client-5.6.35-2.el6.x86_64.rpm
rpm -Uvh --force mysql-community-server-5.6.35-2.el6.x86_64.rpm

service mysqld start

.

Also please refer to: https://github.com/YazaiHu/mysql56-community-install-rpm (install.sh) script.

Highlighted

Re: Mysql 5.6 install errro (Error: Package: mysql-community-server-5.6.35-2.el6.x86_64 (mysql56-community) Requires: perl(DBI))

Expert Contributor

I did the following this, mine issue has been Resolved

1)   Download the “Requires: perl(DBI)” package ,we are using centos 6.8 version, download the
 below RPM  perl-DBI-1.609-4.el6.x86_64.rpm

http://rpmfind.net/linux/rpm2html/search.php?query=perl-DBI

2) Install the perl DBI rpm on Linux server 

[root@centos2 ~]# rpm -ivh perl-DBI-1.609-4.el6.x86_64.rpm
Preparing...                ########################################### [100%]
   1:perl-DBI               ########################################### [100%]
[root@centos2 ~]#
3) [root@hostname ~]# sudo yum install mysql-community-server
Loaded plugins: fastestmirror
Setting up Install Process
Repository HDP-UTILS-1.1.0.19 is listed more than once in the configuration
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package mysql-community-server.x86_64 0:5.6.35-2.el6 will be installed
--> Processing Dependency: mysql-community-client(x86-64) >= 5.6.10 for package: mysql-community-server-5.6.35-2.el6.x86_64
--> Running transaction check
---> Package mysql-community-client.x86_64 0:5.6.35-2.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================================
 Package                                 Arch                    Version                        Repository                          Size
=========================================================================================================================================
Installing:
 mysql-community-server                  x86_64                  5.6.35-2.el6                   mysql56-community                   54 M
Installing for dependencies:
 mysql-community-client                  x86_64                  5.6.35-2.el6                   mysql56-community                   18 M

Transaction Summary
=========================================================================================================================================
Install       2 Package(s)

Total download size: 73 M
Installed size: 324 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): mysql-community-client-5.6.35-2.el6.x86_64.rpm                                                             |  18 MB     00:01
(2/2): mysql-community-server-5.6.35-2.el6.x86_64.rpm                                                             |  54 MB     00:04
-----------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                     11 MB/s |  73 MB     00:06
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
  Installing : mysql-community-client-5.6.35-2.el6.x86_64                                                                            1/2
  Installing : mysql-community-server-5.6.35-2.el6.x86_64                                                                            2/2
  Verifying  : mysql-community-client-5.6.35-2.el6.x86_64                                                                            1/2
  Verifying  : mysql-community-server-5.6.35-2.el6.x86_64                                                                            2/2

Installed:
  mysql-community-server.x86_64 0:5.6.35-2.el6

Dependency Installed:
  mysql-community-client.x86_64 0:5.6.35-2.el6

Complete!
[root@hostname ~]#
4) Verify the packages installed or not 
[root@hostname ~]# rpm -qa |grep mysql
mysql-community-common-5.6.35-2.el6.x86_64
mysql57-community-release-el6-9.noarch
mysql-community-libs-compat-5.6.35-2.el6.x86_64
mysql-community-libs-5.6.35-2.el6.x86_64
mysql-community-client-5.6.35-2.el6.x86_64
mysql-community-server-5.6.35-2.el6.x86_64
[root@hostname ~]#

[root@hostname ~]# service mysqld status
mysqld is stopped
[root@hostname ~]#

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here