Support Questions
Find answers, ask questions, and share your expertise

NIFI Gettwitter HTTP_ERROR: HTTP/1.1 401 authorization Requiered. will attempt to reconnect. ?

New Contributor

I correctly configured the processor in NIFI with the consumer secrte, token ..... etc. from tiwtter apps that i've created.. and i'm connected to internet, Firewalls are down but i always have the error HTTP_ERROR: HTTP/1.1 401 authorization Requiered. will attempt to reconnect.

and i cant strem any data from twitter. Please help me to solve this issue.

Thanks

1 ACCEPTED SOLUTION

Mentor

1832-untitled.png

did you create a Twitter application as the guidelines of Twitter api request? You also need Access Token and Access Secret. link @Malek Ben Salem

View solution in original post

26 REPLIES 26

New Contributor

Hi,

if you are still facing this issue and you already tried to regenerate the key and it didn't work

try to make sure of the clock in your sandbox is set correctly to do so run the following :

1. yum install -y ntp

2. service ntpd stop

3. ntpdate pool.ntp.org

4. service ntpd start

New Contributor

Regenerating 'Consumer Key/Secret' and Access token didn't help. Tried ntpd clock time adjustment. It worked ! !

Thanks guys !!

Contributor

thanks! had this same problem and getting ntpd running properly fixed it.

Explorer

Thanks a ton! Worked for me as well. As he said, if regeneration of the keys didn't work. This should probably fix the issue.

Explorer

Thank you! It worked for me.

New Contributor

I had the same problem, I tired regenerating access key and token

but with no luck

what I found later .. that the time and date on the sandbox was off

so I update the time to the correct one

and create a new app in twitter api

and it works fine

; ;