Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

NIfi and Nifi Registry Integration

avatar

I have 3 nodes NiFi and 1 node Registry instances running.

Registry - SSL enabled and AD-integrated 

NIfi  - SSL enabled and AD-integrated 

 

how can I integrate NiFI with Registry, so I can start using Registry.

 

@MattWho please advice for any recommendations 

 

 

3 ACCEPTED SOLUTIONS

avatar
Super Mentor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Master Collaborator
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Super Mentor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
5 REPLIES 5

avatar
Super Mentor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Explorer

@MattWhothank you for providing this response. I am in the same situation. I tried the steps you mentioned above. My apologies if I am asking a basic question, where can I get help on how I can resolve TLS handshake errors? I am getting the below error -

Error

Unable to obtain listing of buckets: javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

 

After setting up Nifi and Nifi Registry should I be setting up certs to enable ssl connections between nifi and registry? Thanks in advance. 

avatar
Super Mentor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Master Collaborator
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Explorer

@MattWho  @ckumar  thanks for your inputs! I was able to resolve the issue following the steps you mentioned. Much appreciated!