Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 11-04-2025 12:35 PM
nifi is hosted in AKS cluster of node count 3. occasionally we are receiving below errors and node-0 always gets disconnected
Could you please give some inputs or help possible
logs:2025-11-01 01:01:12,444 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated UpdateAttribute[id=9b95428d-2972-38fa-b7cd-20d759b4e749]
2025-11-01 01:01:12,445 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated ExecuteSQLRecord[id=07e8f117-fcdf-39a9-a989-3deb3b467263]
2025-11-01 01:01:12,445 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated UpdateAttribute[id=2be213fa-1965-3303-9e4f-ebbb8e3dec37]
2025-11-01 01:01:12,445 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated StandardProcessGroup[identifier=cd3be53f-130d-3a1c-8e5a-ed86de708fd8,name=fullload-process-configuration]
2025-11-01 01:01:12,445 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated StandardProcessGroup[identifier=36476f9f-018d-1000-ffff-ffff9a57bb5b,name=ifsview-fullload-currentstate]
2025-11-01 01:01:12,445 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated StandardProcessGroup[identifier=059a87b9-2902-326e-9dcf-6f4369cc924e,name=fullload-data-ingestionoperational]
2025-11-01 01:01:12,446 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated StandardProcessGroup[identifier=ca3fa104-6604-32ce-8933-cdc48eaca2e2,name=fullload-data-ingestionanalytics]
2025-11-01 01:01:12,446 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated StandardProcessGroup[identifier=78b00966-4bc8-3525-924f-1605e0bb068b,name=fullload-data-extraction]
2025-11-01 01:01:12,446 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated StandardProcessGroup[identifier=7b0f0ebd-09ad-3fb0-82b7-84b11e68bc23,name=fullload-operational-truncatelandingzonetables]
2025-11-01 01:01:12,447 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated StandardProcessGroup[identifier=45be6018-1c49-3810-9785-7d082054335a,name=fdh-logging-operational]
2025-11-01 01:01:12,447 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated StandardProcessGroup[identifier=681a5022-25b1-30fe-a041-d827aa4785ae,name=fullload-process-configuration]
2025-11-01 01:01:12,447 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated StandardProcessGroup[identifier=bf2be415-018f-1000-0000-00000a313b15,name=fdhoperational-fullload-landingzone]
2025-11-01 01:01:12,448 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated StandardProcessGroup[identifier=d294e6bd-ba08-3a09-a04b-7528ab3745f1,name=deltaprocess-cache-updates]
2025-11-01 01:01:12,448 INFO [Reconnect to Cluster] o.a.n.f.s.StandardVersionedComponentSynchronizer Updated LocalPort[id=bdb77786-6aee-30b2-bfb2-75671f47c5c2, type=OUTPUT_PORT, name=outputportlogging (78ac3d2a-a6d6-3fe2-b9f2-3cdca6956dd7), group=deltaload-data-ingestionanalytics]
2025-11-01 01:01:12,450 INFO [Reconnect to Cluster] o.a.n.c.s.AffectedComponentSet Starting the following components: AffectedComponentSet[inputPorts=[], outputPorts=[], remoteInputPorts=[], remoteOutputPorts=[], processors=[], parameterProviders=[], flowRegistryCliens=[], controllerServices=[], reportingTasks=[]]
2025-11-01 01:01:12,450 INFO [Reconnect to Cluster] o.a.nifi.controller.StandardFlowService Disconnecting node due to Failed to properly handle Reconnection request due to org.apache.nifi.controller.serialization.FlowSynchronizationException: Failed to connect node to cluster because local flow controller partially updated. Administrator should disconnect node and review flow for corruption.
2025-11-01 01:01:12,471 INFO [Reconnect to Cluster] o.apache.nifi.controller.FlowController Will no longer send heartbeats
2025-11-01 01:01:12,471 INFO [Reconnect to Cluster] o.apache.nifi.controller.FlowController FlowController will stop sending heartbeats to Cluster Coordinator
2025-11-01 01:01:12,471 INFO [Reconnect to Cluster] o.apache.nifi.controller.FlowController Cluster State changed from Clustered to Not Clustered
2025-11-01 01:01:12,477 INFO [Reconnect to Cluster] o.a.n.c.l.e.CuratorLeaderElectionManager Cannot unregister Leader Election Role 'Primary Node' because that role is not registered
2025-11-01 01:01:12,477 INFO [Reconnect to Cluster] o.a.n.c.l.e.CuratorLeaderElectionManager Cannot unregister Leader Election Role 'Cluster Coordinator' because that role is not registered
2025-11-01 01:01:12,477 INFO [Reconnect to Cluster] o.a.nifi.controller.StandardFlowService Node disconnected due to Failed to properly handle Reconnection request due to org.apache.nifi.controller.serialization.FlowSynchronizationException: Failed to connect node to cluster because local flow controller partially updated. Administrator should disconnect node and review flow for corruption.
2025-11-01 01:01:12,477 ERROR [Reconnect to Cluster] o.a.nifi.controller.StandardFlowService Handling reconnection request failed due to: org.apache.nifi.controller.serialization.FlowSynchronizationException: Failed to connect node to cluster because local flow controller partially updated. Administrator should disconnect node and review flow for corruption.
org.apache.nifi.controller.serialization.FlowSynchronizationException: Failed to connect node to cluster because local flow controller partially updated. Administrator should disconnect node and review flow for corruption.
Created 11-05-2025 09:54 AM
@Sanga Welcome to the Cloudera Community!
To help you get the best possible solution, I have tagged our NiFi experts @mburgess @MattWho who may be able to assist you further.
Please keep us updated on your post, and we hope you find a satisfactory solution to your query.
Regards,
Diana Torres,Created 11-05-2025 10:41 AM
Thank you,
Matt